Closed Bug 1031563 Opened 5 years ago Closed 4 years ago

[v2.0][v2.1] Feature Proposal: Pop-over App Tray/Launcher

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, enhancement)

ARM
Gonk (Firefox OS)
enhancement
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: Synper311, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:24.0) Gecko/20140610 Firefox/24.0 PaleMoon/24.6.2 (Nightly/Aurora)
Build ID: 20140610142618

Steps to reproduce:

On v2.0/v2.1, the homescreen is vertical with fences. The user can group icons by using the fences, but there is no "sticky" area where the user can place their most used/important apps like in v1.1/v1.2/v1.3, etc.

This represents a regression in usability as the user can now get "lost" on the homescreen when trying to access their most used apps quickly, needing to scroll up and down to find them, instead of having them instantly available.



Expected results:

I propose that the "swipe up to unlock" tray from v1.1 be recycled into a webos Wave Launcher-like pop-over app tray for the users to use.

This tray would be hidden on the screen until the user tap/holds on the bottom edge of the screen and then the up arrow and shading from the v1.1 slide to unlock would show (much like how tap/hold on top edge draws the date and activates the notification tray for sliding), which the user can use to expose the quick launcher area. 
Tapping on an icon would launch & hide the quick launcher. 
The quick launcher can be hidden be tap/hold on the up arrow and dragging it back down (much like hiding the notification panel), or by tapping Home.

The quick launcher would become "sticky" for editing whenever the user tap/holds an icon on the homescreen to manage them. In this way, they can easily place/remove icons from the quick launcher.

Much like with the notifications tray, I believe the quick launcher should be accessible from any app/screen at any time in order to save the user lots of pointless navigating around, especially since the homescreen no longer has the sticky static dock where the user can put their most used apps.
Severity: normal → enhancement
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Component: Gaia → Gaia::Homescreen
I guess that UX is currently working on filling that gap for 2.1.
Flags: needinfo?(jsavory)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi Brett-
Thanks for your comments. We will review on Monday and get back to you same day. I appreciate your comment in terms of highlighting the user need first (as I have requoted here):

> This represents a regression in usability as the user can now get "lost" on
> the homescreen when trying to access their most used apps quickly, needing
> to scroll up and down to find them, instead of having them instantly
> available.

I have responded to dev-gaia- but in case you missed it:

We have looked at past user testing (video): https://www.dropbox.com/s/chce1nm4uj435zh/_home-layout-videos-full.m4v and these are some of the main takeaways:

- regardless of how people organize, definitely frequency of use is a big theme here
- people organize in any myriad of ways, including organizing to be able to see the background photo
- there’s a concept of what I use and “everything else” - my guess is because the download/ install model of apps causes one to install things that I might have only tried or checked out or used once but don’t use very often

What you point out below is most tied to the first takeaway, which is about how people organize around frequency of use. We are working for 2.1 to provide additional organization solutions (content grouping) and I’m happy to share with those at the dev Gaia weekly meeting or elsewhere. 

Regarding how we address this in the 2.0 version of the homescreen, our rationale for vertical scrolling without a dock follows below.

It comes down to the differences in ergonomics between vertical free scrolling and horizontal pagination. I’ll explain our top two hypotheses. As always we are testing these through prototyping, and will adjust if necessary.
- With vertical scrolling, the top of the list is a defacto dock. 
-  With vertical scrolling, it is more annoying than helpful to have a portion of screen real estate obscured.

To go into more detail:

"With vertical scrolling, the top of the list is a defacto dock.”

In our design process, we asked ourselves, "what is a dock"? Functionally it is a mechanism that enables the user to access their favorite apps quickly and reliably. Spatially, it is the Home of the Home. On a horizontal paginated home app, this is expressed as a 4-5 icons that are fixed along the bottom of the screen. They never move. This is great, because pagination is slow. If I am on page 6, I need to swipe 5 times to get back to my first page of apps. With a dock, I can access 4-5 of my favorite apps quickly, no matter where I am, without swiping. On a vertical home app, however, pagination is not a problem. With free scrolling, the user get to the top or bottom of their list very quickly. This makes the top of list analogous to the dock, in so far as it is an area of apps that is easily reached at all times. We see this in Windows Phone, Nokia X and Meego. Users put their favorite apps at the top, and less favorite apps “below the fold”.

"With vertical scrolling, it is more annoying than helpful to have a portion of screen real estate obscured."

If you’ve ever used a mobile site that has a fixed floating header, you know how annoying it is to have your vertical real estate taken away when trying to scroll through content. On a horizontal paginated home app, this is not an issue, because the dock at the bottom never intersects with the apps in the paginated area. On a vertical free scrolling home, however, a dock at the bottom would overlap other apps and obscure significant (eg: 15-25%) of the scrolled real estate. With our larger icons in a 3-icons-per-row arrangement, this would be ever more egregious. Our hypothesis is that a user who is free-scrolling vertically highly values being able to see the full screen height, and would be significantly more annoyed than assisted by having any portion of it obscured.

FWIW, we did sketch an alternate design that incorporates a dock that shows/hides as the user scrolls, analogous to the behavior of the bottom toolbar in Mobile Safari. We’re bearish on this approach, however, because it is simply a slight mitigation on the second issue above. It would still obscure content some of the time, it would add visual noise as it animated in/out, and it would be of questionable benefit, given the first hypothesis above.

> Expected results:
> 
> I propose that the "swipe up to unlock" tray from v1.1 be recycled into a
> webos Wave Launcher-like pop-over app tray for the users to use.
> 
> This tray would be hidden on the screen until the user tap/holds on the
> bottom edge of the screen and then the up arrow and shading from the v1.1
> slide to unlock would show (much like how tap/hold on top edge draws the
> date and activates the notification tray for sliding), which the user can
> use to expose the quick launcher area. 

Thanks for the proposed solution here. As we explore more and more edge gestures on the device, we need to consider the overall system interaction paradigm and how these types of suggestions play into that. 

We're reviewing the prioritization of this user need in light of our targeted user and will definitely consider your proposed solution. In the mean time, thanks for the feedback and we'll get back to you asap.

Thanks!
Jaime
Flags: needinfo?(jsavory) → needinfo?(firefoxos-ux-bugzilla)
Jaime, Thanks for the lengthy & detailed reply.

I appreciate what you're saying with using vertical scrolling and the "noise" of a sticky dock.

What do you think about combining the vertical scrollability with horizontal pagination? On webOS v2.x and above, this was a method users could employ to sort apps.

In my specific use case, I sorted the pages in order of usage/importance from Left -> Right, with apps sorted within each page by alphabetical order (barring some "essentials" that went to the top, like you mentioned above). Each page represented a functional grouping of the apps, much like what we can accomplish in FFXOS v2.1 with the "fences". I had my "Internet" apps, my "Multimedia", my "Utilities", my "GPS/Mapping", my "Homebrew", and my "System" pages.

I agree in the fact that more options on how to sort and arrange are never a bad thing. I really love what you guys have done with the fences, but I still yearn for a "static" dock or an edge-gesture dock like I mentioned above.

Edge gestures are a really powerful way to emulate the functionality of physical buttons without having to waste screen space to draw them, or rely upon certain hardware platforms and designs to have them.

I do hope that more edge gestures are employed in FFXOS, and I do hope you guys give some consideration to my dock concept. For my usage, I want Phone/Messages/Contacts/Camera at my fingertips as close as possible, as those are my go-to functions. Everything else I have on my phone (and I have a lot) are highly situational and sorting through them feels like a pain.

I look forward to any new developments! Being involved in an evolving and dynamic platform is really exciting. Thanks for hearing my suggestion :)
The below is in reply to Justin from the mailinglist, putting here for others to see.

Hey! I found the mailing list finally, haha (The guy who filed the bug/suggestion).

Justin, what you're suggesting is functionally very, very similar to the approach Microsoft have taken with the Windows Phone 7/8.x UI/UX.

On that platform, you have two homescreens, both of infinite vertical length.

The primary homescreen is 100% customizable, and you can "pin" practically anything you want: App shortcuts, live tiles of various information (weather, stocks, etc), contacts, websites, calender events, notes, photos, videos, functions (dialer), shortcuts to system settings, etc.

The secondary homescreen is a alphabetical vertically scrolling list of EVERY app on the phone that can be scrolled, searched/filtered, or jumped through by Alpha letter.

I have 0 objections to this model and have found the WP platform to be exceedingly comfortable and intuitive in use, and is far and away my favorite current platform (webOS holds the honors for MIA platform). The amount of customization you can achieve with this paradigm is just insane and everyone makes their own homescreen how they want, and the power of it all becomes clear once you get it set up. You're presented with a view of information that is tailored to ONLY what you want to see, ONLY how you want to see it, and ONLY where you want it to be. How awesome is that?

My girlfriend has... commandeered? my Nokia Lumia 520, and she uses it daily. Every time I see her, she's tweaked and adjusted her homescreen to suit her mood or what she's doing. Just this week she changed it to reflect the fact that she's doing a lot of design & planning work on a friend's daughter's Quinceanera. So now her homescreen has an object that launches the playlist of songs for the dance, an object that is the gallery of in-progress dress photos, an object that is a gallery of reference photos, an object that is a link to a Pinterest board on Aztec Dance designs, etc. Who knows what her homscreen will be next week!

In my usage, mine was much more spartan and less changeable. I arranged things into simple functional groups that made sense to me and I only put what I felt were "essential" items. The arrangement never changed, as I wanted to be able to navigate it intuitively. This UI/UX model suited us both, which should stand as a testament to how flexible it is.

Using the WP model, the user has the ability to make these functional groupings, though they are currently restricted to only ONE homescreen. I feel like that is too restrictive, and I think if we employed N-number of vertically scrollable horizontal pages with this model, we could have a unique twist on this already really solid interaction paradigm. The key thing is not to blindly copy, but to understand why each platform has ardent supporters, and to learn what lessons each UI/UX can teach us. There is no one interaction model that suits everyone 100% (keep trying though, Apple), and by allowing/establishing a flexible framework that makes sense, FFXOS could better serve its users than the other, more rigid UI/UX models other platforms deploy.

I do hope to see FFXOS take this approach in the future so that the user can mix content with apps. For instance, I'd love being able to have one homescreen that is my speed-dial on FFXOS where I'll have 9 objects that represent Voicemail and the 8 contacts I call most, with picture icons for each person. I'd love to have a homescreen that minds my messages, emails, and social network updates. I'd love a homescreen dedicated to tracking weather and local news/events.
Assigning to Maria for consideration.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(msandberg)
Hi!

Thanks Brett and Justin for your detailed and thought through feedback! The UX team is currently working on refining the spacial model for FxOS and we've considered many different approaches - the multiple pane home screen being one of them. I expect that there will be a proposal ready during the fall that will be shared more broadly. 

When it comes to the vertical home screen we have several features planned that will help improve the navigation issues and danger of the user getting lost:

1. App grouping will allow users to create groups that can be left open (expanded) or closed (collapsed). Grouping will not only help with organization but also provide visual anchors on the homescreen, improving the sense of where the user is. This feature also allow more freedom and the ability for the user to "hack" their homescreen in many ways. For example, one of the use cases above mentioned having 4-5 core apps and a bunch of "others". Now, a user could put their favorite apps on top and one big group collapsed group that contains the "others". 

We are still tweaking the design aspects of this feature but you can check it out on master at any time. Currently you have to turn it on under settings/developer/home screen/app grouping. 

2. CSS scroll nudging will make scrolling on the homescreen more nuanced and help the user "target" the place they want to go to. 

3. Shelves is a concept we are working on that would let users add horizontal bands of content to the homescreen. This would further help visually distinguish different parts of the homescreen and allow for more customization. 

We also have some smaller features planned further down the road to keep improving the homescreen. Do feel free to take a look at the latest build and give us feedback at any point!
Flags: needinfo?(msandberg)
Marla,

Hey Marla, the fences and grouping are still missing the point of having a dock you can call over the screen from anywhere. Quick, easy multitasking to commonly used tasks. 

The process should not be: "Oh, I'm in an app, let me press the home button. Oh, the screen is at the wrong height, let me scroll up or down a bit to find that fence or tap the home button again to jump to the top. Oh, I found it, let me tap it now."

The process should be: "Oh, I'm in an app, let me swipe up and hold, hover over the icon I want in my dock, and release to launch the app."


Now, as for the grouping in Master, fences and grouping sort of help organize the home screen (I still find a single long screen ugly, and for me, unintuitive). I prefer a vertically scrolling horizontal page model where I can easily group icons of certain types. In function, this would be like combining the naming aspect of the groups you have in Master with the pagination [manually paginated, with vertical scrolling] of FFXOS v1.x.

However, combining that with your shelves and groups/fences within the pages would be even better to be perfectly honest. People can have the one screen if they want, and people can divide things up even more granular if they wish. It is a win/win for everyone.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.