Closed Bug 1031571 Opened 7 years ago Closed 7 years ago

Restyled error pages - Try Again button:hover cursor is pointer instead of default

Categories

(Firefox :: Theme, defect)

33 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 33

People

(Reporter: jaramat, Assigned: vtsatskin)

Details

Attachments

(2 files)

Attached image timeout.png
The new visual style of error pages implemented in Bug 982347 looks really sweet and good, but there's this little thing bugging me.

Steps to reproduce:
1. Get an error message page - for example by disconnecting your computer from network and performing a network action in Firefox.
2. Move cursor over the "Try Again" button.

Expected results:
Cursor doesn't change (keeps "cursor: default" CSS).

Actual results:
Cursor changes to a "hand" pointer (has "cursor: pointer" CSS).


Likely, this is determined by Project Chameleon at http://people.mozilla.org/~jgruen/chameleon/#nav1. Then again, the project page clearly says it's a work in progress, so this should be a subject to (discuss to) change.

The "Try Again" button shouldn't use Pointer as a hover cursor. A button is a button, not a link.

Every operating system uses the standard cursor for buttons - even some websites (if they have their own buttons styling, like Google) and all web browsers - including Internet Explorer, both old&new Opera, and Google Chrome do. There's no reason to go against the crowd now - and not ever.

I'd also like to point out that Firefox's inContent preferences styling uses the default cursor for buttons too (which is good).
Valentin, was this intentional?
Flags: needinfo?(vtsatskin)
This was intentional. However, after more consideration I'm going to opt to remove the cursor on the buttons for the following reasons:

* A pointer cursor is meant to give an affordance of intractability on an element. However a button already has enough afforance inherently.
* From a consistency perspective, desktop and web button/controls do not have a pointer cursor on hover so it makes sense that these buttons do not have a pointer.
* inContent preferences also behaves in the aforementioned way, so it makes sense to stay consistent here.
Flags: needinfo?(vtsatskin)
I'll be filing a patch shortly to fix this.
Assignee: nobody → vtsatskin
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch 1031571.patchSplinter Review
Attachment #8451778 - Flags: review?(bmcbride)
Comment on attachment 8451778 [details] [diff] [review]
1031571.patch

Review of attachment 8451778 [details] [diff] [review]:
-----------------------------------------------------------------

You also need to remove the flashing-cursor fix for the retry button at the end of browser/base/content/aboutneterror/netError.css
Attachment #8451778 - Flags: review?(bmcbride) → review-
(In reply to Blair McBride [:Unfocused] from comment #5)
> Comment on attachment 8451778 [details] [diff] [review]
> 1031571.patch
> 
> Review of attachment 8451778 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> You also need to remove the flashing-cursor fix for the retry button at the
> end of browser/base/content/aboutneterror/netError.css

The flashing-cursor fix will still need to apply because of the following rule:

http://hg.mozilla.org/mozilla-central/annotate/340b19c14d3d/browser/themes/shared/in-content/common.css#l51
Comment on attachment 8451778 [details] [diff] [review]
1031571.patch

Review of attachment 8451778 [details] [diff] [review]:
-----------------------------------------------------------------

Pro tip: Re-request review! Only saw this by chance.
Attachment #8451778 - Flags: review- → review+
Attachment #8451778 - Flags: checkin? → checkin+
https://hg.mozilla.org/mozilla-central/rev/45dbfe892807
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.