Empty modules list on android x86

NEW
Unassigned

Status

()

Toolkit
Crash Reporting
4 years ago
3 years ago

People

(Reporter: evilpie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I wanted to look at a crash report for my tablet: https://crash-stats.mozilla.com/report/index/47123619-1106-482d-98ea-17de42140627. The crash report doesn't have any symbols and glandium noticed that the module list is missing.
Wonder if this is a variation on the usual elfhack bustage?
Created attachment 8451779 [details]
maps

If I run minidump_dump on that dump I get:
2014-07-07 13:57:22: minidump.cc:3026: ERROR: MinidumpModuleList could not store module 211/213, libxul.so, 0x85623000+0x2b04000
2014-07-07 13:57:22: minidump.cc:4940: ERROR: GetStream could not read stream type 4
2014-07-07 13:57:22: minidump_dump.cc:115: ERROR: minidump.GetModuleList() failed

Removing the error from that GetModuleList path I can get the data out, there is a list of modules, it just has some overlapping memory ranges or something.

Attached is the /proc/self/maps bit from the minidump.
Flags: needinfo?(mh+mozilla)
I tried using the fixer program that we had used historically but it doesn't seem to produce a working minidump given that input.
Looks like the logic for adding a page between the decompression buffer and the loaded library was broken by bug 920558. That is, there should be a page free between the first read-write libxul.so mapping and the subsequent ones. I don't remember if the fixer was for that particular issue. I think it was for something else.
Flags: needinfo?(mh+mozilla) → needinfo?(ted)
Oh, in fact, the logic is working... it's just assuming something that happens not to be true... I guess we should just revert back to using a page before and a page after... or fix breakpad.
(In reply to Mike Hommey [:glandium] from comment #5)
> or fix breakpad.

You know, those patches that have been sitting for more than a year ;)
What was the needinfo on me for? (Also I am fully shamed by my inability to review those patches.)
Flags: needinfo?(ted)
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #7)
> What was the needinfo on me for? (Also I am fully shamed by my inability to
> review those patches.)

For your thoughts on how to go forward. We can either continue working around it in the linker, get my year-old breakpad patches up-to-date and landed, or fixup breakpad to split /proc/self/maps mappings that have a part in mappings given in report_mapping.
15:42 wlp|tab: Just upgraded Firefox for Android to version 41.0.  It now repeatedly crashes when I scroll enough on http://news.google.com.  Is there a regression on the matter?
15:45 liuche: wlp|tab: hey there - that's not supposed to happen
15:45 liuche: wlp|tab: what device are you using?
15:46 wlp|tab: ASUS MemoPad 10" 32GB WiFi.  Note this device is Intel powered.
15:47 wlp|tab: I was able to scroll a wikipedia page just fine.  After that, I could scroll for longer on Google News.  I think it might have something to do with how fast you move the page.
15:47 nalexander: wlp|tab: can you look in about:crashes and see if you have records?
15:48 wlp|tab: https://crash-stats.mozilla.com/report/index/bp-117de935-42df-481c-92a5-c9c402150922
15:48 firebot: wlp|tab: https://crash-stats.mozilla.com/report/index/117de935-42df-481c-92a5-c9c402150922
15:48 wlp|tab: Stupid bot.
15:48 wlp|tab: firebot bad bot
15:48 firebot cowers.
15:48 wlp|tab: https://crash-stats.mozilla.com/report/index/bp-a2fda163-3ce1-4380-9e45-58cf92150922
15:48 firebot: wlp|tab: https://crash-stats.mozilla.com/report/index/a2fda163-3ce1-4380-9e45-58cf92150922
15:48 wlp|tab: https://crash-stats.mozilla.com/report/index/bp-e9e3d970-6fe4-4d3f-923a-25f8b2150922
15:48 firebot: wlp|tab: https://crash-stats.mozilla.com/report/index/e9e3d970-6fe4-4d3f-923a-25f8b2150922
15:49 nalexander: wlp|tab: do they all look similar?
15:50 wlp|tab: Don't know.  It just crashed while I was scrolling on that last page.
15:50 nalexander: wlp|tab: hmm, looks like stack unwinding is not happy.
15:50 wlp|tab: So it isn't just Google.
15:51 nalexander: wlp|tab: your crashes all look similar, but that might be an artifact of busted stack unwinding.
15:51 wlp|tab: Do you have an Intel device?
15:51 nalexander: ted: snorp: you're the resident stack unwinding experts, especially on x86.  Any hints?
15:51 nalexander: wlp|tab: we have some x86 devices, yes.
15:51 nalexander: wlp|tab: I don't have one myself.
You need to log in before you can comment on or make changes to this bug.