Windows Classic: paragraph drop-down does not show what style is chosen when open00

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
17 years ago
7 years ago

People

(Reporter: TucsonTester2, Assigned: shliang)

Tracking

Trunk
mozilla0.9.7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build ID: 20011002

The paragraph style drop-down on the toolbar in composer does not show what
paragraph style is chosen when the list is opened.  It should somehow represent
what is chosen by a bullet or a check mark.

Reproducible: Always

Steps to Reproduce:
1.Open composer
2.Click on the paragraph style drop-down on the toolbar and choose Heading 1
3.Click on the paragraph style drop-down to expand it

Actual Results:
The menu does not indicate what style is currently selected.  It does highlight
what is chosen, but if you run across the different styles that will go away.

Expected Results:
I would expect that the currently chosen paragraph style would be indicated with
a bullet or checkmark in the menu when it is expanded.

Comment 1

17 years ago
Confirmed on build 2001110703.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Windows Classic: paragraph drop-down does not show what style is chosen when open → Windows Classic: paragraph drop-down does not show what style is chosen when open00

Comment 2

17 years ago
-> shliang@netscape.com
Assignee: hewitt → shliang
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 3

17 years ago
Created attachment 58067 [details] [diff] [review]
selected menuitem is checked

changing all menulists so that selected menuitem is checked

Comment 4

17 years ago
Comment on attachment 58067 [details] [diff] [review]
selected menuitem is checked

sr=hewitt
Attachment #58067 - Flags: superreview+

Comment 5

17 years ago
Comment on attachment 58067 [details] [diff] [review]
selected menuitem is checked

r=andreww
Attachment #58067 - Flags: review+

Comment 6

17 years ago
Why was this done?  This is not how Windows dropdowns behave, and Classic should
be emulating OS widgets.  It doesn't even seem to be a useful enhancement, as
the previously selected item is visible in the widget itself (above the
dropdown).  I think we should back this out pending further discussion.

Comment 7

17 years ago
Upon consultation of the Windows guidelines, it seems that the menus in question
should follow the menu guidelines and include checkmarks next to the current
selection. See pp. 153 where it discusses that "the interface for drop-down list
boxes is similar to that for menus." While no specifics are given, it infers
that the menu guidelines apply thus there should be a mark in a single selection
list. See pg 144 and 136. Additionally with the drop-down lists in the prefs
d.b. having so many items in them, an indication of the current selection is a
helpful navigation guide since the menu title is so far from the user's current
focus. There is no relative gauge in the font size drop downs. The check marks
help users to compare items within the list without the cognitive overhead of
jumping up to look at the title and back down to the list contents repeatedly. 
(Assignee)

Comment 8

17 years ago
this has been backed out
(Assignee)

Comment 9

17 years ago
checking in again - see lori's comment
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
The guidelines do not specifically state that, and indeed it is not how the
standard Windows menulist behaves (i.e., if we were using native controls, this
behavior would not exist).  The point of Classic is to mimic the OS exactly, not
to extend or change the behavior of standard controls, even if we feel they
might be useful enhancements.

Comment 11

17 years ago
You are correct. As I said, the guidelines infer it. Guidelines do just that.
They aren't rules and they can't cover all cases. Just because someone
interprets the guidelines in a particular way doesn't mean they're right for
every situation. In this case, I believe optimizing the feedback for the target
user is the best option. 

Comment 12

17 years ago
Verified on build 2001121203.
Status: RESOLVED → VERIFIED

Comment 13

17 years ago
I don't think that inference is clear at all; and it should be evident from the 
fact that native Windows dropdowns do not exhibit this behavior that this is 
not what the spec intends.  As Joe says in bug 112437,

"We have no intention of "improving" the native widgets, we are trying to 
emulate them as best as possible.  This is a definite WONTFIX."

Indeed, that is the very purpose of Classic, and any attempt to try to improve 
upon the fundamental OS widgets should not be taken lightly.  I still think 
this warrants more discussion if we're going to give the user a different 
experience than that which he has in every other program on his computer, 
especially in the Classic theme, which is intended to be an exact emulation of 
the OS.  I do not think we should open up the can of worms of extending OS 
behavior in Classic, so reopening for more feedback from interested parties.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 14

17 years ago
In general, I agree that the checkmark may be a useful enhancement in such long 
menulists as the Font dropdowns, provided the user understands its purpose.  Of 
course, such long menulists are probably scrollable, which means the checkmark 
won't always be visible (whereas the top part of the widget will).  I'm also 
uncertain of the validity of the scenario you describe without the checkbox, 
that users would constantly have to be looking back up to see the currently 
selected item.  Can't users remember something in short term memory for a few 
seconds?  The only case I can see this possibly being useful in is when you 
have multiple variations of the same font, e.g. Rockwell, Rockwell Bold, 
Rockwell Light, etc. that are in close proximity.  However, few menulists in 
the product are as long as the one in fonts.  (Also, I can only assume that the 
font prefs are geared toward advanced users, as it's not as if the average user 
knows what the fonts on his computer look like without some sort of preview.)

Honestly, as I said, I vote we leave Classic to what it was meant to be -- an 
OS emulation -- and not get into the business of trying to improve upon core 
Windows widgets.
(Assignee)

Comment 15

17 years ago
marking wontfix
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WONTFIX

Comment 16

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.