www.tnt.tv crashes mozilla

RESOLVED DUPLICATE of bug 102936

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 102936
16 years ago
13 years ago

People

(Reporter: Sean Harding, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Mozilla (10-02-01 linux nightly) on FreeBSD crashes when loading http://www.tnt.tv 

On my system, this seems 100% reproducable. Launch a brand new mozilla, type
www.tnt.tv in the location bar, hit enter, and mozilla seg faults.

The page loads ok in Communicator 4.78. I have javascript on (popups disabled)
and Java off. No flash plugin is installed.

Comment 1

16 years ago
very bad code, many unclosed tags, works with 0.9.4 on win2k tho

Comment 2

16 years ago
With flash, real and java 1.1 through 1.3.1 (or so it seems, according to
about:plugins): No crash with a current CVS build, Linux. There is some java on
the page. No crash after a reload either. Clicked around on links, went back -
still no crash. WFM..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
This is fixed on the trunk as of "2001-10-03 15:22"

Please verify with an Oct 4 or newer build.

(I'm basing the "duplicate" designation on the stack I get when I go to this
site with a  debug build from Oct 2:

#0  0x4127ccfb in nsHttpChannel::ProcessResponse (this=0x8a6bd10)
    at nsHttpChannel.cpp:485
#1  0x41284470 in nsHttpChannel::OnStartRequest (this=0x8a6bd10,
request=0x8a4912c, 
    ctxt=0x0) at nsHttpChannel.cpp:2260
#2  0x412abdfa in nsOnStartRequestEvent::HandleEvent (this=0x41f01638)
    at nsRequestObserverProxy.cpp:125
#3  0x4122f5e7 in nsARequestObserverEvent::HandlePLEvent (plev=0x41f01638)
    at nsRequestObserverProxy.cpp:79
#4  0x401e270b in PL_HandleEvent (self=0x41f01638) at plevent.c:590
#5  0x401e251c in PL_ProcessPendingEvents (self=0x80b00e8) at plevent.c:520
#6  0x401e478c in nsEventQueueImpl::ProcessPendingEvents (this=0x80b0018)
    at nsEventQueue.cpp:389
#7  0x413a6724 in event_processor_callback (data=0x80b0018, source=8, 
    condition=GDK_INPUT_READ) at nsAppShell.cpp:184
#8  0x413a630f in our_gdk_io_invoke (source=0x8357fd8, condition=G_IO_IN,
data=0x83693e8)
    at nsAppShell.cpp:77
#9  0x4047aaca in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#10 0x4047c186 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#11 0x4047c751 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#12 0x4047c8f1 in g_main_run () from /usr/lib/libglib-1.2.so.0
#13 0x403a0c69 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#14 0x413a6dba in nsAppShell::Run (this=0x8145438) at nsAppShell.cpp:364
#15 0x40fbe8a4 in nsAppShellService::Run (this=0x8127f88) at
nsAppShellService.cpp:456
#16 0x08059bd4 in main1 (argc=2, argv=0xbffff6c4, nativeApp=0x0) at
nsAppRunner.cpp:1293
#17 0x0805a94a in main (argc=2, argv=0xbffff6c4) at nsAppRunner.cpp:1621
#18 0x405a69cb in __libc_start_main (main=0x805a75c <main>, argc=2,
argv=0xbffff6c4, 
    init=0x8053ff4 <_init>, fini=0x80648bc <_fini>, rtld_fini=0x4000ae60
<_dl_fini>, 
    stack_end=0xbffff6bc) at ../sysdeps/generic/libc-start.c:92
)

*** This bug has been marked as a duplicate of 102936 ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.