doorhanger for new tab shown in wrong (already present) tab which is the opener

RESOLVED DUPLICATE of bug 829225

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 829225
3 years ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Firefox for Android Nightly & Aurora 20140629 on Android 4.1.2, Nexus S

When opening a link in a new tab using the context menu, the geolocation permission doorhanger for the new tab is shown (and only shown) in the tab which opened the new tab.

Steps to reproduce:
1. Search Google for: getusermedia html5 demo
2. Long tap the result html5demos.com/gum (2nd result here) and open it in a new tab.
Actual result: Geolocation permission doorhanger is shown in the tab with the search results. If you switch fast to the new tab, you won't notice it at all. Switching back to the search results will show it.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 829225
You need to log in before you can comment on or make changes to this bug.