If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Slow loading of multiple bugzilla pages simultaneously

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Guilherme Lima, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I follow mozillazine forums and the daily thread about nightlies, and everyday I click on almost every bug that has been fixed on that day.

A few day ago, I noticed that loading the pages have become much much slower than it used to be.

Simpler STR:
1. Go to bug 941841
2. CTRL+Click on a few bugs from the "Depends on" list, fast enough so you get all the pages loading at the same time. (I tested with the bugs from 1012327 to 1014394)

With today's Nightly it took 37s to load the 8 pages.
Testing the other version I have of Firefox (Beta 31), it took 8s.
Firefox Beta (and when it used to finish loading very fast) finishes to load all the pages simultaneously (all the pages show the bugzilla icon at the same time), and now each page finishes loading separately.

I don't if it's a very recent regression or if I just took very long to notice it.

I filled this bug under Networking, but the problem may be somewhere else.
Can you please try to bisect?  A.k.a find the version where this works well for you so we can find the change that might cause it?  Thanks.
(Reporter)

Comment 2

3 years ago
Sorry, the problem is not with Firefox itself.
I tested with a new profile, and it didn't reproduce.
Then I tested my normal profile in safe mode, didn't fix the problem as well.
Any idea what I can do?
(Reporter)

Comment 3

3 years ago
I found out why it didn't happen on the new profile. I need to be logged in on Bugzilla!
When not logged in, the pages load as fast as expected.

Using Firefox Beta I also measured a slower loading of the pages if I'm logged in.
Who may know if the website changed something around the end of June?
(Reporter)

Comment 4

2 years ago
Whatever the problem was, it doesn't happen now. Logged in on bugzilla and opening the 8 tabs now took 16s (way less than the 37s from before).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.