[v2.0][v2.1] Feature Proposal: Waiting Voicemail Status Indication

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: Synper311, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Currently on B2G v2.0 and v2.1, there is no "Voicemail Waiting" icon in the status bar, only as an entry in the Notifications panel.

I propose that the Voicemail Waiting icon be added to the status bar independent of whether or not the Voicemail Waiting status is in the Notifications tray.

Furthermore, I'd like to see the Phone/Dialer app notify the user of a waiting voicemail by highlighting the 1/voicemail key.

These methods would be unmissable, whereas it is easy for the user to accidentally clear a long list of missed notifications and then not be able to see their voicemail is waiting.
Asking our UX team for consideration.

I know I'm not checking my voicemail a lot so I always have some unlistened voicemails and having something always present in the UI would annoy me. With the current design, I can dismiss the notification. But I'm just one user :)
Flags: needinfo?(cawang)
(Reporter)

Comment 2

4 years ago
Understandable, but for me, missing voicemails can be disastrous. 

I oftentimes conduct my work from my phone so being able to easily miss the voicemail status is not a good thing. Especially since I've found FFXOS quite inconsistent in when it chooses to show the notification or not (even when the server has waiting/un-listened voicemails).
Hi, 

Unfortunately, the rule of the status bar is displaying that your device is in a certain "status", for example, "in 3G/ wifi status" or "No SIM inserted status". If there is something we want to notify or remind users, we leave it in notification center. This is the rule we adopt here and if we provide a voicemail icon in status bar, then that will become an exception.

However, I agree with you that we should keep an eye on the consistency of the notification. I'll inform the UX who is in charge of this to review the current behavior and improve it in our future plan.

Thanks!
Flags: needinfo?(cawang)
(Reporter)

Comment 4

4 years ago
Carrie,

If you're looking to court dumbphone users, you should heavily consider making the voicemail icon live in the status bar. It is a familiar and natural UX for those users (of which, I am one).

Comment 5

8 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.