bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

With the classic theme, drop down menu shows highlight of white on light grey instead of white on blue

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
--
major
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: andré, Unassigned, NeedInfo)

Tracking

SeaMonkey 2.25 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
In seamonkey, using the default classic theme,
in drop down menus the background of the current line is changed to light grey instead of a medium blue.

Non-current lines keep their somewhat darker grey, which is unchanged.
The text is changed from black to white, also unchanged.

The result is the current menu line is virtually impossible to read.
(Moving the cursor to another line allows reading it.)

Related factors :
1) This is a regression.  It worked ok in previous releases.

2) A new clean profile, without any additional extensions installed, shows exactly the same problem.
Also with no extensions (including defaults) installed.

3) Bug 197107, a problem with OS X fixed in 2003, showed the same symptoms.  See comment 7 of that bug.  Other comments indicate that it only affected OS X.
It seems that exactly the same bug was accidentally recreated, this time on Linux.
(Reporter)

Comment 1

4 years ago
Ping ?
This is a regression which shouldn't be hard to fix.  (Assuming familiarity with the source code.)
It leaves the current line in menu selection unreadable.
Severity: normal → major
(Reporter)

Comment 2

4 years ago
Ping ???
Still a problem with 2.26.1.

Comment 3

4 years ago
If this is Bug 1016063 then it should be fixed in 2.29
(Reporter)

Comment 4

4 years ago
Problem still present in 2.29.
(Reporter)

Comment 5

4 years ago
Still a problem in 2.30

Comment 6

3 years ago
@andré:
Still a problem with 2.38?
If yes please tell relevant information concerning your Linux
Flags: needinfo?(andr55)
(Reporter)

Comment 7

3 years ago
(In reply to Rainer Bielefeld from comment #6)
> @andré:
> Still a problem with 2.38?
> If yes please tell relevant information concerning your Linux

Hi Rainer
Happy to say the problem is gone.  Since quite a while now.
This may be related to my switching to Maté desktop (a continuation of Gnome2) in place of Gnome3, since there were quite a few similar problems with Gnome3 and other applications.
Otherwise it could be related to faulty gtk3 configuration, affecting many applications I use, which has been fixed.

So I would suggest closing it as fixed (it may be related to the bug fix mentioned in comment 3), if not worksforme.
I'll leave that to you :)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.