Closed Bug 1032106 Opened 5 years ago Closed 5 years ago

[Vertical Homescreen] Pressing the home button returns to top after showing context menu

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

STR
1. Go to the bottom of the homescreen
2. Long press the home button to show the context menu
3. Tap the home button again

Expected results
Tapping the home button should return to the homescreen

Actual
Tapping the home button returns to the homescreen and triggers the animation which makes the homescreen go to the top
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Attached file Github pull request
I assume that this is the correct behavior explained by Jaqueline in bug 1028443 comment 2
Attachment #8447884 - Flags: review?(kgrandon)
Sorry the STR are:

1. Go to the bottom of the homescreen
2. Long press on an empty space in the homescreen to show the context menu
3. Tap the home button again
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Comment on attachment 8447884 [details]
Github pull request

Did not test it, but the code looks simple enough that I will leave an R+ here. Thanks!
Attachment #8447884 - Flags: review?(kgrandon) → review+
Merged in master:

https://github.com/crdlc/gaia/commit/4b1ba4212044e05b49e5d49d5bee80e179182aa9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8447884 [details]
Github pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no regression
[User impact] if declined: after closing context menu the home goes to top
[Testing completed]: added unit tests
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: no changes
Attachment #8447884 - Flags: approval-gaia-v2.0?(bbajaj)
Target Milestone: --- → 2.0 S5 (4july)
Flags: needinfo?(jlorenzo)
Keywords: verifyme
Attachment #8447884 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
(In reply to Cristian Rodriguez (:crdlc) from comment #0)
> STR
> 1. Go to the bottom of the homescreen
> 2. Long press the home button to show the context menu
> 3. Tap the home button again

Verified for the context menu. For the cards view (after long pressing the home button), see bug 1028443.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jlorenzo)
Issue is verified fixed on 2.1 flame 

When pressing the home button wile in context menu, screen no linger returns user to the top of the home screen.


Flame 2.1

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141125001201
Gaia: 1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko: db893274d9a6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-] → [VH-FL-blocking-][VH-FC-blocking-] [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-] [QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking-] [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.