Entering a list in a table can break the table if the cell previously contained a list that was removed by backspacing

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: TucsonTester2, Assigned: mozeditor)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4)
Gecko/20011002 Netscape6/6.2
BuildID:    20011002

If you remove a list from a cell by going to the next cell in the table and then
backspacing completely through the cell that contains the list, and then try to
put a list in that same cell again, the table will break at that point.  The
result will be two separate tables with the list between them.

Reproducible: Always
Steps to Reproduce:
1.Open a blank page in composer
2.Click on Table, create a table with 2 rows and 3 columns
3.Click in the second cell of the top row
4.Click on the List button (doesn't matter whether it is ordered or unordered)
5.Click in the third cell of the top row
6.Press the backspace key 3 times (this should remove the list and put the
cursor in the first cell of top row)
7.Click on the second cell of the top row
8.Click on the List button.

Actual Results:  You get a table with a single cell, then a bullet (or number)
for the list, and then a second table with 5 cells in it (2 on first row, three
on the second row).

Expected Results:  Expected one table with a bullet (or number) in the second
cell of the first row.

In step 6 of steps to reproduce, if you only hit the backspace twice instead of
3 times, the cursor will disappear.  If you then hit the List button without
clicking on anything, it will put the list correctly, but if you click on the
cell and then click on the list button, it breaks the table.  If you only
backspace within the cell containing the list without doing anything in another
cell, then hitting list button does not break table.

The steps to reproduce I have given are the easiest way to guarantee the table
breaks.  However, from playing with it further, it appears to also happen if
after first putting in the list (steps 1-4) you then go to another cell, type in
anything (a single letter will do), and then click on the cell with the list,
backspace through it to remove it, and then try to enter a list in that same
cell again.

Comment 1

17 years ago
Neeto. marking EDITORBASE
Assignee: syd → cmanske
Whiteboard: EDITORBASE

Comment 2

17 years ago
In step 5, using backspace from the 3rd cell does nothing -- it doesn't go into
the 2nd cell and delete anything.
Syd: Could you reproduce this?
If the bug does exist, it is an editor core bug -- giving to Joe.
Assignee: cmanske → jfrancis
Component: Editor: Composer → Editor: Core

Comment 3

17 years ago
I am seeing the same results (step 5 backspace does nothing) on the 20011031
trunk build.  But I am still seeing the problem described in the original report
on the 20011022 branch build. 

I am resolving WORKSFORME, since no more changes will be goind into the branch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 4

17 years ago
verified.
You need to log in before you can comment on or make changes to this bug.