Can't align multiple lines of text if each line has a different alignment

VERIFIED WORKSFORME

Status

()

Core
Editor
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: TucsonTester2, Assigned: Joe Francis)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE)

(Reporter)

Description

17 years ago
Build ID: 20011003

If you have at least two lines with different alignments in composer you can not
select them in order to align them at the same time.

Reproducible: Always

Steps to Reproduce:
1.Open composer
2.Click on the center align button on the toolbar
3.type in: 1
4.Hit enter, change the alignment to right align and type in: 2
5.Click Edit -> Select All
6.Click on the left allignment button on the toolbar

Actual Results:
Only the first line changes alignment.  The same thing will happen if you have
even more lines of text.  Only the top line will change alignment.

Expected Results:
I would expect that all of the lines of text would change to the same alignment
  since they are all highlighted when I click the align button.

Comment 1

17 years ago
EDITORBASE
Assignee: syd → cmanske
Whiteboard: EDITORBASE

Comment 2

17 years ago
editor core bug.
Assignee: cmanske → jfrancis
Component: Editor: Composer → Editor: Core

Comment 3

17 years ago
This works for me on build 2001111203. 

Resolving WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.