[v2.1] Fix failure in test_settings_wifi.py

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Assigned: viorela)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Test test_settings_wifi.py has failed in the latest master because the connected message was not located. From the screenshot, we can see that the status of the wifi we connect to is not displayed on the page, as the wifi is in the bottom of the page. 
I think we can fix that by scrolling to the wifi element, before getting its status. 
I can't reproduce the issue locally, as the network I connect to is placed up in the available wifi list.
 
Traceback (most recent call last):
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/marionette_test.py", line 170, in run
testMethod()
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_wifi.py", line 21, in test_connect_to_wifi_via_settings_app
wifi_settings.connect_to_network(self.testvars['wifi'])
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/wifi.py", line 51, in connect_to_network
lambda m: m.find_element(*self._connected_message_locator).text == "Connected")
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/wait.py", line 122, in until
rv = condition(self.marionette)
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/wifi.py", line 51, in <lambda>
lambda m: m.find_element(*self._connected_message_locator).text == "Connected")
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/marionette.py", line 1193, in find_element
response = self._send_message('findElement', 'value', **kwargs)
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/decorators.py", line 35, in _
return func(*args, **kwargs)
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/marionette.py", line 613, in _send_message
self._handle_error(response)
File "/var/jenkins/workspace/b2g.flame.mozilla-central.ui.non-smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/marionette.py", line 647, in _handle_error
raise errors.NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
NoSuchElementException: NoSuchElementException: Unable to locate element: #wifi-availableNetworks li.active small

Gaia      de14e61098b742251b34f856e48649db8bed552c
Gecko     https://hg.mozilla.org/mozilla-central/rev/b6408c32a170
BuildID   20140630040201
Version   33.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

Jenkins report:
http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Flame/job/b2g.flame.mozilla-central.ui.non-smoketest/105/HTML_Report/
(Assignee)

Comment 1

4 years ago
Created attachment 8448042 [details]
screenshot.png
(Assignee)

Updated

4 years ago
Assignee: nobody → viorela.ioia

Comment 2

4 years ago
I thought we already had a scrollIntoView here.. maybe it was removed at some point :(
(Assignee)

Comment 3

4 years ago
I investigated this, but I was not able to reproduce the failure locally. 
I checked the code in the connect_to_network() method, and there is a scroll to the wifi we want to connect to, on the wifi's list page: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/wifi.py#L34
After we tap on that wifi, we enter the password, then we go back to the wifi's list. 
We can add a scroll to the wifi status before: https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/wifi.py#L34. I added a patch with that fix.
(Assignee)

Comment 4

4 years ago
Created attachment 8451558 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/21222
Attachment #8451558 - Flags: review?(zcampbell)
Attachment #8451558 - Flags: review?(florin.strugariu)
Attachment #8451558 - Flags: review?(florin.strugariu) → review+
https://github.com/mozilla-b2g/gaia/commit/352bf0912998afb5d4cfe52da54c5253da2da89f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment #8451558 - Flags: review?(zcampbell)
You need to log in before you can comment on or make changes to this bug.