Windows XP/2K, CJK language: Can't print Danish/French character with accent (ISO-8859-1)

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Kasumi, Unassigned)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Build ID=2001-10-05-05-0.9.4
OS = Win XP Ja, Professional, Version 2002

1. Launch Navigator
2. access to above URL
3. Click Print icon or select from File/Print
4. You will have missing all accent 

Print on Postscript printer, there is no problem.  
Netscape 4.78 has no problem.
I tested multiple Win XP Ja, Professional, Version 2002 machines,results are the
same.

Updated

17 years ago
Summary: Win XP: Can't print French accent(ISO-8859-1). → Win XP: Can't print French accent(ISO-8859-1).

Comment 1

17 years ago
I'm not surprised by this. Some applications (including
Microsoft Word 2000!) have a problem printing Latin 1
accents under CJK locales. 
Can you switch the locale to Latin 1 country like US temporariky
and see if that does not fix the problem? 
Another workaround is to see if the printing dialog offers an option
to print as image rather than as text. This will probably slow down
printing some but should print OK. 

Comment 2

17 years ago
> Some applications (including Microsoft Word 2000!) ...

Correction. I should have said instead:

"Some applications (including Microsoft PowerPoint 2000!).."



Comment 3

17 years ago
One more thing.

Can you check to see if "Edit | Appearance | Fonts | Allow documents to
use other fonts" is checked or not when you have the problem? How about when
the option is not checked? Do you still have the printing problem?

Comment 4

17 years ago
Question to ftang: Is there a problem in using the full set of 
  glyphs for printing contained in a font like Arial/Times
  due to a locale difference?

Comment 5

17 years ago
Switching QA contact to ylong.

Adding intl keyword.
Keywords: intl
QA Contact: sujay → ylong

Comment 6

17 years ago
CC'ing shanjian.

Updated

17 years ago
Target Milestone: --- → mozilla1.0.1
(Reporter)

Comment 7

17 years ago
Additionally, Danmark accent(?)(ISO-8859-1) either such å.
http://www.netscape.com/da 
OS: Windows 2000 → Windows XP
(Reporter)

Comment 8

16 years ago
tested 2002-04-12-08-1.0.0
Can print properly such accent characters as Custom in PageSetup/Header&footer.

Comment 9

16 years ago
I cannot reproduce this problem on WinXP Chinese .
Can QA be clear do they see the problem or NOT.
I cannot understand comments like:
>Additionally, Danmark accent(?)(ISO-8859-1) either such å.
>http://www.netscape.com/da 
Does this comment means "å" won't be print correctly, or it will be print correctly?

Could you write "Print correctly" or "Print incorrectly"  when you type in 
your comments, thanks

>tested 2002-04-12-08-1.0.0
>Can print properly such accent characters as Custom in PageSetup/Header&footer.

But how about html pages ? can you print those accent characters in html properly ?

Comment 10

16 years ago
I cannot reproduce this on Win XP Chinese, either but on 
Windows 2000 (locale set to Japanese), neither NN7 nor IE6 
will print accent marks. 

On a printout, IE6 has unncessary question marks
that don't exit on the page.

NN7 does not print accent marks, either. It also prints
capital "E" on top of some characters (usually on top of the
first character of a word.) Bullet symbols turn into question marks.
(Reporter)

Comment 11

16 years ago
tested on 7.0 JA build on win XP JA
Word pad has the same problem for DA, FR.  

Comment 12

15 years ago
retargeting
Target Milestone: mozilla1.0.1 → Future

Comment 13

11 years ago
I can't believe this would still be true.
serge, do you see this?
(In reply to comment #13)
> serge, do you see this?

My current setup is not suited to reproduce this bug: no WXP, no (working) printer, ...
Moreover, if I understand this bug correctly, it's reported on W2K/WXP with CJK language ... which I "never" had.

FWIW:

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111204 Minefield/3.0b2pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111202 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

On my W2K fr, (currently) I can test Print Preview only, with a new profile:
<http://fr.yahoo.com/>: "àéë" display correctly.
<http://www.netscape.com/da>: obsolete ("The page you have requested cannot be found. Propeller Home")

(If you have something more specific for me to test, CC me again)
Assignee: dcone → nobody
QA Contact: amyy → printing
Summary: Win XP: Can't print French accent(ISO-8859-1). → Windows XP/2K, CJK language: Can't print Danish/French character with accent (ISO-8859-1)
Target Milestone: Future → ---

Comment 15

10 years ago
phiw, can you see this?

Comment 16

10 years ago
(In reply to comment #15)
> phiw, can you see this?

Can't really help, I don't have a printer connected to my Win XP SP2 Japanese (locale) running of a virtual machine on top of OS X.
That said, both the French Yahoo page, and a couple of test pages display those characters correctly up to Print Preview.
Tested with Minefield B5.

Comment 17

9 years ago
I can't reproduce this, so marking WFM as per the last 3 comments.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.