href attribute isn't set for links in the "repos" menu, so unable to open repo X directly in new tab

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: emorley, Assigned: camd)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
1) Go to https://treeherder.mozilla.org/
2) Open the repos menu.
3) Middle mouse click one of the non-default repos (eg fx-team) to open in a new tab (or just use the context menu copy the URL)
4) Note the resultant URL

Expected:
https://treeherder.mozilla.org/ui/#/jobs?repo=fx-team

Actual:
https://treeherder.mozilla.org/ui/

This is because the href attribute isn't set:
<a href="" class="repo-link ng-binding" ng-click="changeRepo(repo.name)">fx-team</a>

Marking blocking since low hanging fruit, and given the issues discussed in bug 1032220, I'm using one tab per repo - so often need to load an additional tab for a new repo - and with this bug I have to open treeherder in another tab (which opens to the default repo) and then switch to the desired repo, which takes a lot longer.
(Assignee)

Updated

4 years ago
Assignee: nobody → cdawson
(Reporter)

Updated

4 years ago
Priority: -- → P2
(Reporter)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
Created attachment 8449744 [details] [review]
Pull request
(Assignee)

Comment 2

4 years ago
https://github.com/mozilla/treeherder-ui/commit/4b48b341aa09519cd38dcd54ca535bc3a3b19e43
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 years ago
Thank you - opening in a new tab works well, however I think the plus sign is maybe just a duplicate of the check box? I think without the plus sign the UX is still clear enough perhaps?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

4 years ago
Ed-- Actually, the check box adds the repo as watched, but not load the resultsets, and leaves the window open.  The "+" sign will add it as watched, loads that repo's resultsets and closes the window.

So, without the "+" to switch to a new repo in the current window, you would check it, close the repo panel, and then click on the repo name in the top (black) bar.  

I'm fine to remove it if it just feels like clutter.  I just thought it would be convenient.  :)
(Reporter)

Updated

4 years ago
Flags: needinfo?(emorley)
(Reporter)

Comment 5

4 years ago
(In reply to Cameron Dawson [:camd] from comment #4)
> I'm fine to remove it if it just feels like clutter.  I just thought it
> would be convenient.  :)

Ah ok I see the difference now. I think the problem is that the UX isn't overly clear, so I fear it might be more confusing than helpful at the moment? Perhaps we can remove the plus signs and have another think in the future, once the other bugs are resolved :-)
Flags: needinfo?(emorley)
(Assignee)

Comment 6

4 years ago
Ed--  Yeah, good point.  OK.  I'll remove that.
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 8

3 years ago
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/c4121dfd9229d1936893dc6a4dad4ad795f4cd6c
fix bug 1032463 - click repo link opens new tab
plus for add to watch and view, link opens new tab

https://github.com/mozilla/treeherder/commit/83bbbc7a4651a6fb6f049c7e0359c8681953f44a
Merge pull request #89 from mozilla/repo-link-new-tab

fix bug 1032463 - click repo link opens new tab
You need to log in before you can comment on or make changes to this bug.