Full page screenshot fails to properly render big sites

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
3 months ago

People

(Reporter: nagisa, Unassigned)

Tracking

33 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Running --fullpage screenshot on bigger pages (but not quite as big to hit bug 766661) will result in oddly rendered page.

For reproduction probably any news portal with a lot of content on the homepage will do. See the attachments too.
(Reporter)

Comment 1

5 years ago
Created attachment 8448312 [details]
Hummingbird feed
(Reporter)

Comment 2

5 years ago
Created attachment 8448315 [details]
Screen shot of news portal 15min.lt

This image was heavily compressed as it is 20MB in PNG.
Thanks Simonas, I hope that whatever workarounds we have for bug 766661 will do for this one too.
See Also: → bug 766661
Duplicate of this bug: 1187311
From duplicate bug 1187311:

Two possibilities:

1) Trigger a notice: Show a notice why no screenshot can be made (too large canvas)
2) Capture it anyways in slices.
(In reply to J. Ryan Stinnett [:jryans] (use ni?) (on PTO July 27 - 29) from comment #5)
> From duplicate bug 1187311:
> 
> Two possibilities:
> 
> 1) Trigger a notice: Show a notice why no screenshot can be made (too large
> canvas)

We should at least do this, ASAP.

> 2) Capture it anyways in slices.

IMO this is pretty interesting, especially if we replace the message in 1) with a message about what we did.
In my opinion when an image is too large we should use multiple canvases to capture slices and then manually reassemble the image from canvas data... that way we only need to output a single file.
(Reporter)

Comment 8

3 years ago
jryans, this bug is different from bug 766661. In this bug pages aren’t too long to fit into canvas at all, they just render incorrectly. I don’t have too much knowledge about canvas internals, but I’ve worked on screenshotting tool before and I find them to be distinct enough issues to have different bugs filed for them.

miker, canuckistani: you all probably meant to comment on bug 766661 as well, for the reasons stated above.
(Reporter)

Comment 9

3 years ago
Err, I seem to have confused numbers a bit. I meant the duplicate bug 1187311 is duplicated into a wrong bug (this one) and should be duplicated into bug 766661 instead.
(In reply to Simonas Kazlauskas [:simukis] from comment #8)
> jryans, this bug is different from bug 766661. In this bug pages aren’t too
> long to fit into canvas at all, they just render incorrectly. I don’t have
> too much knowledge about canvas internals, but I’ve worked on screenshotting
> tool before and I find them to be distinct enough issues to have different
> bugs filed for them.

Ah fair enough, I'll try to clean up the mess...

Do you have any more precise data about what triggers this bug vs. bug 766661?  Is it just "somewhat tall, but not really tall" that matters?
Flags: needinfo?(simonas+bugzilla.mozilla.org)
(Reporter)

Comment 11

3 years ago
As far as I remember yes, its all that mattered. 

However, I am unable to reproduce this bug anymore on stable, so am inclined to simply close this now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(simonas+bugzilla.mozilla.org)
Resolution: --- → WORKSFORME

Updated

6 months ago
Product: Firefox → DevTools

Updated

3 months ago
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.