Dragging Link to Bookmarks "Folder" Doesn't Work

VERIFIED DUPLICATE of bug 96504

Status

SeaMonkey
Bookmarks & History
P5
normal
VERIFIED DUPLICATE of bug 96504
16 years ago
13 years ago

People

(Reporter: Luke deGruchy, Assigned: Paul Chen)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010914
BuildID:    2001092020

This is a bug that is specific to the Linux version of Mozilla.  When a user
drags the link (the icon beside the URL text in the URL text/drag-down box) to
the Bookmarks "folder", it does not allow the user to drag the link to a
specific sub-folder as it does in the Windows version.  The Bookmarks folder
instead stays open for a period of time and then closes after clicking something
else a few times.

Reproducible: Always
Steps to Reproduce:
1.Point mouse pointer at icon besides URL text in browser.
2.Click and drag the icon to the bookmarks folder.
3.Move the link down the list of bookmarks.

Actual Results:  The bookmarks folder is opened, but it gives the same result as
a user who is simply click on the folder to find a link to a site.

Expected Results:  The bookmark icon should be draged down, as a moving line
between bookmarks, that the user may place either in the root bookmark
directory, or within a sub-directory.  Once the user lets go of the mouse
button, the new bookmark should be placed in the desired directory.

Depending on the build used, the bookmarks folder will either stay open for a
long time, or close quickly.  This problem is specific to the latest version,
0.9.4, because the feature had not been implemented in previous versions.  This
feature works perfectly in the Windows version, but not in the Linux version.
->bookmarks
Assignee: pchen → ben
Component: XP Apps → Bookmarks
QA Contact: sairuh → claudius

Comment 2

16 years ago
Confirming. This fails for me on RedHat 7.1, Gnome 1.4, Mozilla 2001100906.

The bookmarks folder the submitter is speaking of is the toolbar bookmarks. When
I tried to drag a bookmark into there, not only could I not drag it to an
appropriate folder, the menu would not go away and I could click on no other
window, forcing me to kill mozilla from another virtual screen.

Comment 3

16 years ago
Confirming
Status->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

16 years ago
This happened to me on win2k with 2001101117 build. When I drag a bookmark and
hold it on a bookmark folder (either displayed on toolbar, or through
Toolbar->Bookmarks->Personal Toolbar Folder) the sub-folders don't get
displayed. Please verify. Thanx.
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW
(Assignee)

Comment 6

16 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 96504 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.