Closed Bug 1032522 Opened 8 years ago Closed 8 years ago

Provider for Google Calendar crashes Thunderbird 24.6.0

Categories

(Calendar :: Provider: GData, defect)

x86_64
Windows 8.1
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1061363

People

(Reporter: crlinder, Unassigned)

Details

(Keywords: hang)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

I updated Thunderbird to 24.6.0.  Now when I start Thunderbird, it hangs at the point where it prompts me for my password.  Disabling the extension Provider for Google Calendar stops this behavior


Actual results:

Thunderbird hangs at the point where it prompts me for my password.


Expected results:

I should have been able to enter my password and proceed using the program.
What version of Lightning do you use?
What version of Provider for Google Calendar do you use?
Component: Untriaged → Provider: GData
Flags: needinfo?(crlinder)
Product: Thunderbird → Calendar
Version: 24 → unspecified
Severity: normal → critical
Keywords: hang
Same problem here, I believe. Thunderbird hangs on launch, immediately after the "Portable Apps" splash screen. An empty white dialog box appears with title "Google Calendar Login" -- the cursor becomes the 'working' animation -- unless I click on the box, in which the cursor stays normal pointer. If I force a close via the OS, the box disappears and TB continues to load. Despite all this, the TB calendar seems to work (can read/write to my main Google calendar).

Programs: Thunderbird 24.6.0, Lightning 2.6.6, Provider for Google Calendar 0.25.
Platform: Windows 7 Professional, 64-bit
(In reply to Rich S. from comment #2)
> Same problem here, I believe. Thunderbird hangs on launch, immediately after
> the "Portable Apps" splash screen. An empty white dialog box appears with
> title "Google Calendar Login" -- the cursor becomes the 'working' animation
> -- unless I click on the box, in which the cursor stays normal pointer. If I
> force a close via the OS, the box disappears and TB continues to load.
> Despite all this, the TB calendar seems to work (can read/write to my main
> Google calendar).
> 
> Programs: Thunderbird 24.6.0, Lightning 2.6.6, Provider for Google Calendar
> 0.25.
> Platform: Windows 7 Professional, 64-bit

I see some part of the problem. As someone suggested, I let the non-responsive box remain on screen for a few minutes. Then a dialog appears, also titled "Google Calendar Login" with entry fields for calendar address (initially filled in) and password (initially blank). In this case the calendar which appears I know is a "read only" calendar (corporate events) and it was created as such in Lightning. (should it be asking for a password? not sure). A few minutes later, another blank dialog appears superimposed titled "Password Required" without buttons. It too is unresponsive after several minutes. (per Process Explorer, TB is using 12-13% CPU resources during this hung session). For now I deleted the read-only calendar from the Calendar tab. Not the best solution.
The problem is not only with the read-only calendars, as my calendars are modifiable.  I am using the most recent versions of TB (24.6.0), Lightning (2.6.6) and Provider (0.25).  

(In reply to Rich S. from comment #3)
> (In reply to Rich S. from comment #2)
> > Same problem here, I believe. Thunderbird hangs on launch, immediately after
> > the "Portable Apps" splash screen. An empty white dialog box appears with
> > title "Google Calendar Login" -- the cursor becomes the 'working' animation
> > -- unless I click on the box, in which the cursor stays normal pointer. If I
> > force a close via the OS, the box disappears and TB continues to load.
> > Despite all this, the TB calendar seems to work (can read/write to my main
> > Google calendar).
> > 
> > Programs: Thunderbird 24.6.0, Lightning 2.6.6, Provider for Google Calendar
> > 0.25.
> > Platform: Windows 7 Professional, 64-bit
> 
> I see some part of the problem. As someone suggested, I let the
> non-responsive box remain on screen for a few minutes. Then a dialog
> appears, also titled "Google Calendar Login" with entry fields for calendar
> address (initially filled in) and password (initially blank). In this case
> the calendar which appears I know is a "read only" calendar (corporate
> events) and it was created as such in Lightning. (should it be asking for a
> password? not sure). A few minutes later, another blank dialog appears
> superimposed titled "Password Required" without buttons. It too is
> unresponsive after several minutes. (per Process Explorer, TB is using
> 12-13% CPU resources during this hung session). For now I deleted the
> read-only calendar from the Calendar tab. Not the best solution.
Flags: needinfo?(crlinder)
What steps are you taking to force a close via the OS.  I assume you're working through Task Manager, but what processes are you killing?

(In reply to Rich S. from comment #2)
> Same problem here, I believe. Thunderbird hangs on launch, immediately after
> the "Portable Apps" splash screen. An empty white dialog box appears with
> title "Google Calendar Login" -- the cursor becomes the 'working' animation
> -- unless I click on the box, in which the cursor stays normal pointer. If I
> force a close via the OS, the box disappears and TB continues to load.
> Despite all this, the TB calendar seems to work (can read/write to my main
> Google calendar).
> 
> Programs: Thunderbird 24.6.0, Lightning 2.6.6, Provider for Google Calendar
> 0.25.
> Platform: Windows 7 Professional, 64-bit
Very strange.  The problem disappeared without my actively doing anything to solve it.  My guess is that there was some sort of interaction with one of my other add-ons and that when one (or more) of those add-ons updated automatically, the conflict went away.  I can't think of anything else that would account for the problem resolving itself without my actively updating programs.

Here is the list of my add-ons in case it will help with determining the cause of the problem.  I'll also include their version numbers, but if my guess is correct, the actual offending version will be earlier than the ones presented here.  

Attachement Extractor 1.3.5.1
Compact Header 2.08
ExQuilla for Microsoft Exchange 31.0.1135
Extra Folder Columns 1.1.5
Lightning 2.6.6
Provider for Google Calendar 0.25
Quicktext 0.9.11.5
Signature Switch 1.6.12

If I had to guess, I'd put my money on ExQuilla since the hang occurred when I was presented with the password entry for my Microsoft 365-based e-mail at work.
(In reply to Randy Linder from comment #5)
> What steps are you taking to force a close via the OS.  I assume you're
> working through Task Manager, but what processes are you killing?
> 
> (In reply to Rich S. from comment #2)
> > Same problem here, I believe. Thunderbird hangs on launch, immediately after
> > the "Portable Apps" splash screen. An empty white dialog box appears with
> > title "Google Calendar Login" -- the cursor becomes the 'working' animation
> > -- unless I click on the box, in which the cursor stays normal pointer. If I
> > force a close via the OS, the box disappears and TB continues to load.
> > Despite all this, the TB calendar seems to work (can read/write to my main
> > Google calendar).
> > 
> > Programs: Thunderbird 24.6.0, Lightning 2.6.6, Provider for Google Calendar
> > 0.25.
> > Platform: Windows 7 Professional, 64-bit

I have more success quickly killing apps with Microsoft System Internals' Process Explorer (freeware) than the TM, so I always use that. In this situation, I had to kill the main TB thread.

The only other TB apps I have are "Color Folders 1.1" and "TB Message Filter Import/Export Enhanced 1.0.3" -- both were disabled during my testing.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061363
You need to log in before you can comment on or make changes to this bug.