Use the WebSMS API for wiping text messages

RESOLVED WONTFIX

Status

Firefox OS
FindMyDevice
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: ggp, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Reporter)

Description

4 years ago
Even though factory reset does delete SMS messages on some devices, we can't rely on it always doing so. Instead, we should erase them ourselves with the WebSMS API.

Updated

4 years ago
blocking-b2g: --- → 2.0?
Sorry I couldn't understand the neccesity of using WebSMS API for removing the message database...Since all the databases are stored in device data partition and factory reset should erase them, I don't see any exeption that makes factory reset uable to clear the partition, and if we could not clear the partition directly, how could you expect using the webapi is a more reliable method? Or you did facing the problem that factory reset failed to remove the data?
(Reporter)

Comment 2

4 years ago
(In reply to Steve Chung [:steveck] from comment #1)
> Or you did facing the problem that factory reset failed to
> remove the data?

Not specifically with SMS, but we did observe factory reset having inconsistent behavior across devices for contacts, which is why we filed bug 1030838. On my Fireweb, I've found that factory reset does indeed erase contacts, while I've seen people report that it doesn't happen on the Flame (I don't have a Flame with me at the moment, so I couldn't reproduce it myself yet).

We haven't had any issues with SMS yet, so this bug is here just for investigation at this point. If, as you say, there's no possibility of factory reset failing to erase messages, I don't mind resolving this as INVALID, but I'd like to get a bit more testing on the Flame first.
backlogging this until we know the speculation for what the bug is filed is true.
blocking-b2g: 2.0? → backlog
(Reporter)

Comment 4

4 years ago
:dhylands and :gerard-majax just confirmed over IRC that factory reset is indeed guaranteed to erase both contacts and sms messages, so we don't need this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.