Firefox OS responses stop on june 26th

RESOLVED FIXED

Status

Input Graveyard
Submission
P1
normal
RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

Details

(Whiteboard: u=user c=feedback p= s=input.2014q2)

There haven't been any Firefox OS responses since June 26th.

This bug covers figuring out why and fixing it.
Grabbing it to work on now.
Assignee: nobody → willkg
Priority: -- → P1
Summary: firefox os responses stop on june 26th → Firefox OS responses stop on june 26th
It only affects Firefox OS, so it's probably related to some problem with the API. I tweaked the API on Thursday. All the tests passed, so this is something not covered by the tests.

Depending on what the issue is, we should add a unit test or a smoketest for it.
Rrr... I moved some things around and the new API view router wasn't marked as csrf_exempt, so all POSTs to it were failing.

Fixed, pushed to stage, tested using the app manager (I <3 the app manager now) and then pushed it to production.

One possibly good thing is that anyone who tried to leave feedback would have gotten the "oops--something went wrong" message. The form saves all the data locally, so if they try to submit again later, it'll submit everything they wrote. Thus I contend some of the input we lost will eventually get in.

We should write the Firefox OS smoketests. That's covered in bug #1021155. I'll add a note there and call this a day.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
I figured out the problem with the unit tests and fixed it in:

https://github.com/mozilla/fjord/commit/ac856eb

So we don't need to have the smoketest implemented to catch these issues in the future.
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.