mouse clicks do not work, menus won't open

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: laurent.savaete, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
After a certain amount of time running thunderbird, menus will stop working and responding to mouse clicks. Main menu and main toolbars are affected, but certain buttons like "send" in email composer still perform as expected.
It is possible that some user action triggers the problem, but I have not identified it.

Not working means the button will display normal "click" visual behaviour, but no action is triggered.

Thunderbird needs to be restarted to fix the issue.

This is the same issue as the one affecting firefox (https://bugzilla.mozilla.org/show_bug.cgi?id=528829). Issue probably lies with some shared library.

No other application on my computer is affected by the problem, so it is not a window manager issue. Running Linux Mint Petra with Mate as window manager. Firefox 29 and Thunderbird 24.5.0, but the issue has been around for a while.
(Reporter)

Comment 1

4 years ago
Firefox issue is https://bugzilla.mozilla.org/show_bug.cgi?id=903761, not the one mentioned above.

Comment 2

4 years ago
Laurent, Does it happen in version 31?  With Thunderbird started in safe mode?
Flags: needinfo?(laurent.savaete)

Comment 3

4 years ago
This is very prominent in all versions since 4.x, just don't touch the 
computer for an hour, then both thunderbird and firefox will not open any
of its menus, last tested was 31.2.0 (TB and FF) on Solaris x86 version,
profile/safe makes no difference. The bug is very reliably reproduceable 
since 30.x, before it was a little bit random to get there.

Comment 4

4 years ago
Chris, can you perhaps determine with the users what this might be related to?  Sounds like it would be something core related
Flags: needinfo?(chris.ramsden)

Updated

4 years ago
See Also: → bug 903761

Comment 5

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> Laurent, Does it happen in version 31?  With Thunderbird started in safe
> mode?

Wayne, using TB 31.2.0 and FF 36 (nightly) with e10s on, I don't seem to hit the problem anymore. However, I've always seen the problem happen at random, sometimes after days of leaving the apps open. It's been 10 days now, but I might revert to you with bad news...

Comment 6

3 years ago
WFM based on comment 5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(laurent.savaete)
Flags: needinfo?(chris.ramsden)
Resolution: --- → WORKSFORME

Comment 7

3 years ago
No, it's not WFM. Clearly reproducible here with TB 31.8.0 ESR on Openindiana
151a9 (aka OpenSolaris). Just happened again before writing this comment. It is
100% reproducible by just waiting an hour or so and not touching it at all.
Nothing interesting in the browser console, though.
Please reopen.

Comment 8

3 years ago
Sorry, FF, not TB.
You need to log in before you can comment on or make changes to this bug.