[dolphin]No response on homescreen, because there is a 'fadeout' but no'active' class in <div id=homescreen...>

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
7 months ago

People

(Reporter: yang.zhao, Unassigned)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:-, b2g-v1.4 affected)

Details

(Whiteboard: [sprd328761])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8448552 [details]
'fadeout' but no 'active' for homescreen div

It appears occasionally, one is by manully,steps:
1,launch the contact app to do some operation
2,long press the home button to kill the contacts, but need to slide more than once to kill it
3,then there is no response when touch the homescreen.This means couldn't slide the homescreen and no response when clicking the app icons on homescreen

From the app-manager, there is a 'fadeout' class in "<div id='homescreen'...>",but no 'active' class.
(Reporter)

Comment 1

4 years ago
hi,James
   Please help to find someone to see this issue.Thank you.
Flags: needinfo?(james.zhang)
Whiteboard: [sprd328761]
blocking-b2g: --- → 1.4?
status-b2g-v1.4: --- → affected
Flags: needinfo?(james.zhang)
Flags: needinfo?(wchang)
Flags: needinfo?(ttsai)
Flags: needinfo?(ryang)
Hi Evelyn,

Can you have someone check this one out?
Flags: needinfo?(wchang) → needinfo?(ehung)
Per Comment2, kindly ask for Evelyn's further analysis.Thanks!
Flags: needinfo?(ryang)

Comment 4

4 years ago
Luke, can you work with Alive to have a quick idea? Thanks.
Flags: needinfo?(ehung) → needinfo?(lchang)
Yang,

can you provide the STR for this and if this has also been reproduced on Flame?
We're a bit short on information here and it will be hard to move forward.
Flags: needinfo?(yang.zhao)
(Reporter)

Comment 6

4 years ago
(In reply to Wayne Chang [:wchang] from comment #5)
> Yang,
> 
> can you provide the STR for this and if this has also been reproduced on
> Flame?
> We're a bit short on information here and it will be hard to move forward.
Sorry,we don't have the STR. STEPS in comment 1 is what I did before the issue occurs, but only occurs once by now.Our QA also meet this issue after running monkey test.
Flags: needinfo?(yang.zhao)
So far, I can't reproduce this bug manually, either. I'll try putting some logs to dig more information.
Flags: needinfo?(lchang)

Comment 8

4 years ago
(In reply to yang.zhao from comment #6)
> (In reply to Wayne Chang [:wchang] from comment #5)
> > Yang,
> > 
> > can you provide the STR for this and if this has also been reproduced on
> > Flame?
> > We're a bit short on information here and it will be hard to move forward.
> Sorry,we don't have the STR. STEPS in comment 1 is what I did before the
> issue occurs, but only occurs once by now.Our QA also meet this issue after
> running monkey test.
It's once issue. Is it still necessary 1.4?
Flags: needinfo?(ttsai)

Comment 9

4 years ago
(In reply to yang.zhao from comment #6)
> (In reply to Wayne Chang [:wchang] from comment #5)
> > Yang,
> > 
> > can you provide the STR for this and if this has also been reproduced on
> > Flame?
> > We're a bit short on information here and it will be hard to move forward.
> Sorry,we don't have the STR. STEPS in comment 1 is what I did before the
> issue occurs, but only occurs once by now.Our QA also meet this issue after
> running monkey test.
Hi Zhao: How often does it happen in QA monkey tests?
(Reporter)

Updated

4 years ago
Flags: needinfo?(yaoyao.wu)

Comment 10

4 years ago
(In reply to thomas tsai from comment #9)
> (In reply to yang.zhao from comment #6)
> > (In reply to Wayne Chang [:wchang] from comment #5)
> > > Yang,
> > > 
> > > can you provide the STR for this and if this has also been reproduced on
> > > Flame?
> > > We're a bit short on information here and it will be hard to move forward.
> > Sorry,we don't have the STR. STEPS in comment 1 is what I did before the
> > issue occurs, but only occurs once by now.Our QA also meet this issue after
> > running monkey test.
> Hi Zhao: How often does it happen in QA monkey tests
Hi thomas,

The probability is 1/8.

Comment 11

4 years ago
Hi Luke,

Mind if you take this blocker. Also, per your comment 7, can you provide a patch that can print more logs for our partner to reproduce it and collect the logs.
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(lchang)
Hi Ivan,

Sure, here is the patch:
https://github.com/luke-chang/gaia/commit/8c76dec00af20ea7daf2d271a3cd614e8d9bead5.diff


Hi Yang,

Both Tzu-Lin and I think this bug may be similar to Bug 1031225. The patch above is the same as Tzu-Lin provided in that bug. Could you please help to apply this patch and get some logs after running monkey test again?

Thanks.
Flags: needinfo?(lchang) → needinfo?(yang.zhao)
Assignee: nobody → lchang
Hi Yang,

We've tried running monkey test many times but can't reproduce this issue at our side. I'd like to know if you have any idea. Thanks.
(Reporter)

Comment 14

4 years ago
I think maybe it's related with bug 1031225.Since the log patch you gave in comment 12 will print a lot of logs, I have asked Tzu-Lin to give me another log patch and wait for our QA to reproduce the issue.Maybe we can wait for the log to see if there is any information that could help.

@yaoyao It seems that sprd328761 reproduced yesterday, have you found any new information? Please comment here, thank you!
Flags: needinfo?(yang.zhao)

Comment 15

4 years ago
(In reply to yang.zhao from comment #14)
> I think maybe it's related with bug 1031225.Since the log patch you gave in
> comment 12 will print a lot of logs, I have asked Tzu-Lin to give me another
> log patch and wait for our QA to reproduce the issue.Maybe we can wait for
> the log to see if there is any information that could help.
> 
> @yaoyao It seems that sprd328761 reproduced yesterday, have you found any
> new information? Please comment here, thank you!
Yes,the issue reproduced again yesterday.After running a long time monkey test, our tester long press the home button ,the issue reproduced.
The corresponding code is:
case 'cardviewbeforeshow':
          // Fade out the homescreen before showing the cards view to avoid
          // having it bleed through during the transition animation.
          this.getHomescreen().fadeOut();
          break;
The code leads to homescreen in "fadeout" .
Flags: needinfo?(yaoyao.wu)

Comment 16

4 years ago
While trying to analysis the scene of bug 1031225 ,I reproduced the issue accidentally. Because both homescreen and Email are active ,so I use 

var childs = document.querySelectorAll("#windows .appWindow");
var appDiv = childs[1]; //child[1]refers to E-mail
appDiv.parentNode.removeChild(appDiv)

to get rid of the active Email app. After that the phone return to normal.
I try to enter Calendar app ,but the phone reacts slowly,so I long press the home button try to kill the app,after pressing the button ,the homescreen get into "fadeout".
(Reporter)

Comment 17

4 years ago
Created attachment 8455921 [details]
0-main-22-05-22.log.zip

hi,Luke
  Reproduce again! After running monkey test, the phone turns out to be slow but still normal, then launch several apps and long press home button to kill them, the issue occurs.
  The attachment is the main log with your log patch.
Flags: needinfo?(lchang)
Hi Yang,

I still can't reproduce this issue with our latest gaia. I'm wondering which revision of gaia you're using for monkey test. Thanks.
Flags: needinfo?(lchang) → needinfo?(yang.zhao)
(Reporter)

Comment 19

4 years ago
@yaoyao
   Please see comment#18 and tell Luke the revision of gaia. Thank you!
Flags: needinfo?(yang.zhao) → needinfo?(yaoyao.wu)
Seems we found a possible solution. Please refer to Bug 1031225 comment 23 and see if it can resolve all of these relevant bugs.
See Also: → bug 1031225, bug 1019419

Comment 21

4 years ago
Hi! Luke,

Any update?

--
Keven
Flags: needinfo?(lchang)
Hi Yang,

Could you please confirm if the patch in Bug 1031225 comment 23 can resolve this issue or not? Thanks a lot.
Flags: needinfo?(lchang) → needinfo?(yang.zhao)
(Reporter)

Comment 23

4 years ago
I'm not following the issue now,so add yaoyao to answer this question.
Flags: needinfo?(yang.zhao)

Comment 24

4 years ago
(In reply to Luke Chang [:lchang] from comment #22)
> Hi Yang,
> 
> Could you please confirm if the patch in Bug 1031225 comment 23 can resolve
> this issue or not? Thanks a lot.
Hi Luke and Yang,
   The tester need more time to run monkey test to confirm. I'll test you the result as soon as the tester gives the result .

Comment 25

4 years ago
(In reply to yaoyao.wu from comment #24)
> (In reply to Luke Chang [:lchang] from comment #22)
> > Hi Yang,
> > 
> > Could you please confirm if the patch in Bug 1031225 comment 23 can resolve
> > this issue or not? Thanks a lot.
> Hi Luke and Yang,
>    The tester need more time to run monkey test to confirm. I'll test you
> the result as soon as the tester gives the result .
Hi Luke and Yang,
     It seems that the patch in Bug 1031225 comment 23 can't resolve this issue.
Flags: needinfo?(yaoyao.wu) → needinfo?(lchang)
Hi Luke, May you please kindly update any progress ? Thanks a lot.
Hi Rachelle and Yaoyao,

This issue still can't be reproduced at our side by neither hand nor monkey test. I need more time to figure it out and will update my progress here as soon as possible.
Flags: needinfo?(lchang)

Comment 28

4 years ago
[Blocking Requested - why for this release]:
Is it still a blocker?


Per comment 27, we need our QA's help to reproduce this issue on our monkey test.
blocking-b2g: 1.4+ → 1.4?
Keywords: qawanted
This bug does NOT repro on: Flame 1.4

Actual Result: Following the STR in Comment 0, I'm unable to get this behaviour on the Flame device.

Repro Rate: 0/25

Environmental Variables:
Device: Flame 1.4
Build ID: 20140804033126
Gaia: 9377274b17200a60cebcd2427d489a7756c4cc72
Gecko: 93e736da9863
Version: 30.0 (1.4)
Firmware Version: v122
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Unable to reproduce on flame/monkey.

minusing for now until further occurrences are seen.
blocking-b2g: 1.4? → -

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Assignee: lchang → nobody

Comment 31

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.