i'd like to see necko push all public CID's and ContractID's into nsNetCID.h. this file should be used to document the interfaces implemented by a particular class specified by a CID and/or ContractID. i have already added a couple classes to this file over the past year, and i think it would be good to transition the rest of necko.
hey darin, the scheme that we came up with for deailing with public contract-ids is to create separate header files for each public "component" and put its contract-id and related stuff in there... the reason for separate headers was to make it easier for doxygen style documentation... and to allow components to change (more or less) independently from each other :-) take a look at the bottom of http://www.mozilla.org/projects/embedding/EmbedInterfaceFreeze.html -- rick
rick: that sounds good... could you point me to a sample component header file?
I can't think of any 'component headers' that you can use for reference (jud, please correct me if i'm wrong)... So, you can be the first :-) -- rick
do you have a naming convention for these? a preferred location in the tree? consider for example, nsLoadGroup. could you give me an example of what a component header for this should roughly look like? obviously, i can't call it nsLoadGroup.h ... what should it be called then?
punt -> 0.9.9
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+, topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword. Please send any questions or feedback about this to firstname.lastname@example.org. You can search for "Moving bugs not scheduled for a project" to quickly delete this bugmail.
mass futuring of untargeted bugs
-> default owner
11 years ago