If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

heritageonline.com.au - Secure login to demo login page won't work

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
RESOLVED FIXED
16 years ago
2 years ago

People

(Reporter: Ian Peake, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4+) Gecko/20011002
BuildID:    2001100208

(see steps to reproduce below)
Something buggy/unimplemented in Mozilla Javascript?

Works in Netscape 4.77 opera on same machine/OS.
Works in IE5.5.

Ian Peake

Reproducible: Always
Steps to Reproduce:
1. Open http://secure.heritageonline.com.au/NETBANKING/netbanking.html
2. Click on DEMO SITE (personal) on the left.
3. Follow instructions in popup window for secure login (demo). Fails

Actual Results:  Heritage site reports failed login.

Expected Results:  Heritage site reports succesful login.

Comment 1

16 years ago
confirming on Win2k with build 2001100403.
The Virtual Keyboard uses bad JavaScript code:

if (navigator.appName == "Netscape") {
		document.layers['Keypad'].left = 210 + x
		document.layers['Keypad'].top = 280 + y
	}else{
		document.all['Keypad'].style.left = 210 + x
		document.all['Keypad'].style.top = 280 + y

Should be moved to Tech Evangelism.
OS: Linux → All

Comment 2

16 years ago
Olivier is correct. Here is another sample of the HTML:


if (navigator.appName == "Netscape") {
  document.write("<layer ID='Copyright' NAME='Copyright'                                                                  
                                  STYLE='position:absolute;top:150;left:0'>")
}else{
  document.write("<div ID='Copyright' NAME='Copyright'                                                                    
                                  STYLE='position:absolute;top:500;left:100'>")
}


To see this, note the following: 

1. Start at http://secure.heritageonline.com.au/NETBANKING/netbanking.html
2. Click the "DEMO SITE (personal)" link on the left
3. This opens a window to https://online.hbs.net.au/banking/HBSdemo.html
4. This redirects to https://online.hbs.net.au/ScriptsV2/login2.asp,
   which has the bad HTML


Reassigning to Tech Evangelism -
Assignee: rogerl → momoi
Status: UNCONFIRMED → NEW
Component: Javascript Engine → English: Non-US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → jonrubin
Version: other → unspecified

Updated

16 years ago
Summary: Secure login to Heritage Online's demo login page won't work → heritageonline.com.au - Secure login to demo login page won't work
works now.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

16 years ago
Marking WORKSFORME as FIXED is to be set only when a specific patch fixed a bug.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Yes, it now works for me.

Now it doesn't actually work on the *real* login page (*sigh*).
(Not sure whether this is because something got hardcoded into Mozilla
for the demo or because Heritage only fixed the demo page.)

Reproducible: Always

Steps to reproduce:
0. [assuming one has a *REAL* account with Heritage]
1. Open http://secure.heritageonline.com.au/NETBANKING/netbanking.html
2. Click on Personal Netbanking on the left.
3. Follow instructions in popup window for secure login. Fails.

Actual Results:  Virtual keyboard doesn't jump around. Heritage site reports
failed login.

Expected Results:  Virtual keyboard jumps around as keys are pressed, as in demo
page. Heritage site reports succesful login.

Next I'll email Heritage.  I can also add another tech evangelism bug if you like.

Ian
(Reporter)

Comment 7

16 years ago
Sent message to heritage reporting new status.
so reopen ;(

please don't fill another bug, we have enough ;)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 9

16 years ago
Now works for me, both on the demo page and via the personal netbanking link.

NOTE: Something makes me think we have a high risk of regression here, because
the ``magic floating keyboard'' (apparently a security mechanism) doesn't
jump around on the ``personal netbanking'' page the way it does on the demo
page.
(Reporter)

Comment 10

15 years ago
Now works for me.  Floating keyboard jumps around as per windows.
Presumably the bug can now be closed.

Ian
..and close again
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jonrubin → english-other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.