Intermittent java-exception | java.lang.RuntimeException: Unable to create service com.android.systemui.SystemUIService: java.lang.NullPointerException at android.app.ActivityThread.handleCreateService(ActivityThread.java:2263)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({intermittent-failure})

Trunk
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Android 4.0 Panda mozilla-central debug test jsreftest-2 on 2014-07-01 06:54:20 PDT for push ffb8b976548b

slave: panda-0758

https://tbpl.mozilla.org/php/getParsedLog.php?id=42858832&tree=Mozilla-Central

{
07:46:11     INFO -  REFTEST TEST-START | Shutdown
07:46:31     INFO -  INFO | automation.py | Application ran for: 0:35:30.024214
07:46:31     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpZRHwW5pidlog
07:46:31     INFO -  Contents of /data/anr/traces.txt:
07:46:32  WARNING -  PROCESS-CRASH | java-exception | java.lang.RuntimeException: Unable to create service com.android.systemui.SystemUIService: java.lang.NullPointerException at android.app.ActivityThread.handleCreateService(ActivityThread.java:2263)
07:46:32     INFO -  WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
07:46:32     INFO -  REFTEST INFO | runreftest.py | Running tests: end.
07:46:34     INFO -  --------- beginning of /dev/log/system
07:46:34     INFO -  07-01 07:11:01.296 I/ActivityManager( 1402): START {act=android.intent.action.MAIN flg=0x10000000 pkg=org.mozilla.fennec cmp=org.mozilla.fennec/.App (has extras)} from pid 1917
07:46:34     INFO -  07-01 07:11:01.375 I/ActivityManager( 1402): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=2136 uid=10047 gids={3003, 1015, 1006}
07:46:34     INFO -  07-01 07:11:04.781 I/ActivityManager( 1402): Process com.android.systemui (pid 1623) has died.
07:46:34     INFO -  07-01 07:11:04.781 W/ActivityManager( 1402): Scheduling restart of crashed service com.android.systemui/.SystemUIService in 301293ms
07:46:34     INFO -  07-01 07:11:04.828 I/ActivityManager( 1402): Start proc com.android.systemui for restart com.android.systemui: pid=2157 uid=1000 gids={1015, 3002, 3001, 3003}
07:46:34     INFO -  07-01 07:11:14.953 I/ActivityManager( 1402): Start proc org.mozilla.fennec.UpdateService for service org.mozilla.fennec/org.mozilla.gecko.updater.UpdateService: pid=2213 uid=10047 gids={3003, 1015, 1006}
07:46:34     INFO -  07-01 07:11:15.148 I/ActivityManager( 1402): No longer want com.android.contacts (pid 1699): hidden #16
07:46:34     INFO -  07-01 07:16:06.085 D/SystemUIService( 2157): loading: class com.android.systemui.statusbar.tablet.TabletStatusBar
07:46:34     INFO -  07-01 07:16:06.085 D/SystemUIService( 2157): running: com.android.systemui.statusbar.tablet.TabletStatusBar@411ec850
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): FATAL EXCEPTION: main
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): java.lang.RuntimeException: Unable to create service com.android.systemui.SystemUIService: java.lang.NullPointerException
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.app.ActivityThread.handleCreateService(ActivityThread.java:2263)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.app.ActivityThread.access$1600(ActivityThread.java:123)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1201)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.os.Handler.dispatchMessage(Handler.java:99)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.os.Looper.loop(Looper.java:137)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.app.ActivityThread.main(ActivityThread.java:4424)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at java.lang.reflect.Method.invokeNative(Native Method)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at java.lang.reflect.Method.invoke(Method.java:511)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at dalvik.system.NativeStart.main(Native Method)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): Caused by: java.lang.NullPointerException
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.systemui.statusbar.tablet.HeightReceiver.onReceive(HeightReceiver.java:62)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.systemui.statusbar.tablet.HeightReceiver.registerReceiver(HeightReceiver.java:71)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.systemui.statusbar.tablet.TabletStatusBar.makeStatusBarView(TabletStatusBar.java:438)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.systemui.statusbar.StatusBar.start(StatusBar.java:64)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.systemui.statusbar.tablet.TabletStatusBar.start(TabletStatusBar.java:390)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at com.android.systemui.SystemUIService.onCreate(SystemUIService.java:93)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	at android.app.ActivityThread.handleCreateService(ActivityThread.java:2253)
07:46:34     INFO -  07-01 07:16:06.085 E/AndroidRuntime( 2157): 	... 10 more
07:46:34     INFO -  07-01 07:16:26.093 W/ActivityManager( 1402): Timeout executing service: ServiceRecord{4137aef8 com.android.systemui/.SystemUIService}
07:46:34     INFO -  07-01 07:16:26.101 I/ActivityManager( 1402): Crashing app skipping ANR: ProcessRecord{41370130 1623:com.android.systemui/1000} Executing service com.android.systemui/.SystemUIService
}
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.