Closed Bug 1032961 Opened 6 years ago Closed 6 years ago

[B2G][2.0][SIM Lock] The strings on "Enter SIM PIN" page is not translated.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 unaffected)

RESOLVED DUPLICATE of bug 1030094
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected
b2g-v2.1 --- unaffected

People

(Reporter: ychung, Unassigned)

Details

(Keywords: regression, Whiteboard: LocRun2.0)

Attachments

(2 files)

Description:
The strings "SIM PIN", "Skip", and "Done" on the "Enter SIM PIN" page are NOT translated in ALL language. 

Pre-requisite: SIM PIN is enabled in Settings.

Repro Steps:
1) Update a Flame to BuildID: 20140630000201.
2) Set the device to any language other than English.
3) Restart the phone ensuring SIM PIN is enabled in settings. 
4) Unlock the screen when restarted, and check the strings on "Enter SIM PIN" page.


Actual:
The strings "SIM PIN", "Skip", and "Done" are not translated properly, and appears in English.

Expected:
All strings are translated properly to the test language.

Note:
- The strings "SIM PIN", "Skip", and "Done" are also not translated on the "PIN was incorrect" pages.
- The Tested in Swahili, French, Italian, Spanish, Japanese, Russian, Greek, German, and Tamil.

Environmental Variables:
Device: Flame 2.0
BuildID: 20140630000201
Gaia: c0c8ad187c0466285f2580531e09f8322996f561
Gecko: d4dc609bcc8a
Version: 32.0a2 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro Frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/12101/
See attached: screenshot, logcat
Attached image NotTranslatedSIMPIN.png
This issue DOES reproduce on Buri 2.0:

Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140630000201
Gaia: c0c8ad187c0466285f2580531e09f8322996f561
Gecko: d4dc609bcc8a
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The strings "SIM PIN", "Skip", and "Done" are not translated properly, and appears in English.
----------------------------------------------

This issue does NOT reproduce on Flame 1.4 and Flame 2.1:

Flame 2.1

Environmental Variables:
Device: Flame Master
BuildID: 20140630040201
Gaia: de14e61098b742251b34f856e48649db8bed552c
Gecko: b6408c32a170
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Flame 1.4

Environmental Variables:
Device: Flame 1.4
BuildID: 20140630000201
Gaia: aa896d5db1b4929f3bf31a0f4bb7de50530222a8
Gecko: 8cba60bc12ef
Version: 30.0 (1.4) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

All strings are translated properly to the test language.
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
This is a regression from 1.4. These strings were translated properly on 1.4 so nominating this 2.0?
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030094
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.