Closed Bug 1032998 Opened 6 years ago Closed 6 years ago

[B2G][System]: Enter PUK code screen not translated for multiple languages for phrases "Confirm New PIN" "Create PIN" and "PUK Code"

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 unaffected)

RESOLVED DUPLICATE of bug 1030094
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected
b2g-v2.1 --- unaffected

People

(Reporter: mclemmons, Unassigned)

Details

(Keywords: regression, Whiteboard: LocRun2.0)

Attachments

(3 files)

Attached file Logcat PUK Code Screen
User enters three incorrect SIM PINs and arrives at the Enter PUK Code screen. The phrases “PUK Code” “Create PIN (must contain 4 to 8 digits) and Confirm New PIN appear untranslated for a minimum 15 languages.

Prerequisites:
1. SIM PIN is enabled in settings.

Repro Steps:
1) Update a Flame to 20140630000201
2) Restart the phone
3) When prompted to enter a SIM PIN, put in the incorrect pin 3 times. 
4) Observe device behavior

Actual:
The phrases “PUK Code” “Create PIN (must contain 4 to 8 digits) and Confirm New PIN appear untranslated for a minimum 15 languages.

Expected:
The phrases “PUK Code” “Create PIN (must contain 4 to 8 digits) and Confirm New PIN appear translated for all languages.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140630000201
Gaia: c0c8ad187c0466285f2580531e09f8322996f561
Gecko: d4dc609bcc8a
Version: 32.0a2 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: (3/3, 100%)
Link to failed test case: https://moztrap.mozilla.org/manage/case/12106/
See attached: (screenshot – 1 in Tamil, 1 in Italian, logcat)
The untranslated languages the issue reported in Comment 0 applies to are: Turkish, Serbian Latin, Serbian, Slovak, Russian, Romanian, Brazilian Portuguese, Polish, Dutch, Macedonian, Italian, Hungarian, Croatian, French, and Spanish.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This issue does reproduce on Buri 2.0 following the STR from Comment 0. The phrases "PUK Code" "Create PIN (must contain 4 to 8 digits)" and "Confirm New PIN" are not translated for multiple languages.

Environmental Variables:
Device: Buri 2.0
Build ID: 20140630000201
Gaia: c0c8ad187c0466285f2580531e09f8322996f561
Gecko: d4dc609bcc8a
Version: 32.0a2 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

----------------------------------------------------------------------------------------------------

This issue does not reproduce on Flame 2.1 or Flame 1.4 following the STR from Comment 0. The phrases "PUK Code" "Create PIN (must contain 4 to 8 digits)" and "Confirm New PIN" are translated for multiple languages.

Environmental Variables:
Device: Flame Master
Build ID: 20140630040201
Gaia: de14e61098b742251b34f856e48649db8bed552c
Gecko: b6408c32a170
Version: 33.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Flame 1.4
Build ID: 20140630000201
Gaia: aa896d5db1b4929f3bf31a0f4bb7de50530222a8
Gecko: 8cba60bc12ef
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Nominating this 2.0? since this is a regression from 1.4. 

The phrases "PUK Code" "Create PIN (must contain 4 to 8 digits)" and "Confirm New PIN" were translated correctly for multiple languages on 1.4.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
blocking-b2g: 2.0? → 2.0+
Is this the same problem we have in bug 1030094?
Flags: needinfo?(gandalf)
NI GAndalf to see if he can help. Maybe related some way to issue in Bug 1030094 ?
Yes, it's a dupe.
Flags: needinfo?(gandalf)
Ok marking as resolved duplicate as per commnt 8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1030094
blocking-b2g: 2.0+ → ---
You need to log in before you can comment on or make changes to this bug.