Add jshint and jsbeautify to events service

RESOLVED FIXED

Status

Webmaker
Events
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gvn, Assigned: gvn)

Tracking

Details

(Whiteboard: [tech-debt][july25])

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Add standard jshintrc and jsbeautifyrc and create grunt tasks for them.
(Assignee)

Updated

4 years ago
Whiteboard: [tech-debt] → [tech-debt][july11]
(Assignee)

Comment 1

4 years ago
Created attachment 8449064 [details] [review]
https://github.com/mozilla/webmaker-events-service/pull/47

Note: This patch is just for jshint.
Attachment #8449064 - Flags: review?(aki)
Comment on attachment 8449064 [details] [review]
https://github.com/mozilla/webmaker-events-service/pull/47

R+ as-is, but made a suggestion based on kate's Gruntfile from webmaker.org
Attachment #8449064 - Flags: review?(aki) → review+
(Assignee)

Updated

4 years ago
Whiteboard: [tech-debt][july11] → [tech-debt][july25]
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1030298
(Assignee)

Comment 4

4 years ago
Created attachment 8458324 [details] [review]
https://github.com/mozilla/webmaker-events-service/pull/77

Here comes the beautification...and some tweaks to pass jshint.
Attachment #8458324 - Flags: review?(cade)

Updated

4 years ago
Attachment #8458324 - Flags: review?(cade) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.