Requests can be submitted without a description

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: peterbe, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Steps to reproduce, go to https://air.mozilla.org/manage/suggestions/539/
and click the "Approve" button. It fails to submit to the correct form.
(Reporter)

Comment 1

4 years ago
There is no bug. Well, maybe. 

The reason it refuses to turn it into a real event is because the requested event doesn't have a description. 

I guess the bug is that Rainer was allowed to submit it without a description. Events have to have a description. In Rainer's case if he doesn't have a description he should use the short description as the description instead. 

The short term solution is to reject the event and explain to Rainer to cut the short description and put it into the long description and submit again. 

I'm going to work on making it impossible to submit a request without a description.
(Reporter)

Updated

4 years ago
Summary: Pressing "Approve" doesn't actually submit the right form → Requests can be submitted without a description
Sounds like the right answer.
(Reporter)

Comment 3

4 years ago
Created attachment 8449040 [details]
Screenshot 2014-07-01 16.10.49.png

I'm genuinely curious how Rainer managed to save the requested event without a description. I can't leave it empty. Even if I just enter an single whitespace. Really have no idea how this could have happened.
(Reporter)

Comment 4

4 years ago
Hi Rainer, 

We had some trouble processing your New Hires video. The problem was that you had managed to enter a "Short description" but no "Description". See the screenshot in comment 3 which visually explains that we can't figure how the heck you managed to do that. 

Do you have any idea how you managed to save it without enter a description. Was there some strange edit that might explain this?
Flags: needinfo?(rcvillink)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 5

4 years ago
I can't remember either but I think I made a "period" .... that's what I usually do if there is a description needed and I don't have one.
Flags: needinfo?(rcvillink)
(Reporter)

Comment 6

4 years ago
I tried putting a period too but that didn't work in terms of reproducing it. 

Perhaps some day we'll get a more clear case to reproduce and we can reopen this bug that day.
You need to log in before you can comment on or make changes to this bug.