Intermittent test_bug434998.xul | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]

RESOLVED DUPLICATE of bug 1032783

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 1032783
4 years ago
4 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=42868859&tree=Mozilla-Inbound
Windows 7 32-bit mozilla-inbound debug test mochitest-other on 2014-07-01 10:24:29 PDT for push 265a7db19092

slave: t-w732-ix-002



10:36:45     INFO -  2955 INFO TEST-END | chrome://mochitests/content/chrome/editor/composer/test/test_bug338427.html | finished in 264ms
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:45     INFO -  ++DOMWINDOW == 229 (1C85C200) [pid = 2192] [serial = 2538] [outer = 1B0AC400]
10:36:45     INFO -  2956 INFO TEST-START | chrome://mochitests/content/chrome/editor/composer/test/test_bug434998.xul
10:36:45     INFO -  ++DOMWINDOW == 230 (1C85DA00) [pid = 2192] [serial = 2539] [outer = 1B0AC400]
10:36:45     INFO -  ++DOCSHELL 22513800 == 15 [pid = 2192] [id = 567]
10:36:45     INFO -  ++DOMWINDOW == 231 (1D0CA200) [pid = 2192] [serial = 2540] [outer = 00000000]
10:36:45     INFO -  ++DOMWINDOW == 232 (1C860200) [pid = 2192] [serial = 2541] [outer = 1D0CA200]
10:36:45     INFO -  [Parent 2192] WARNING: NS_ENSURE_TRUE(nsContentUtils::GetCurrentJSContext()) failed: file c:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/docshell/base/nsDocShell.cpp, line 8685
10:36:45     INFO -  ++DOMWINDOW == 233 (1C8D7E00) [pid = 2192] [serial = 2542] [outer = 1D0CA200]
10:36:46     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:46     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:46     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:46     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:46     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:46     INFO -  ###!!! [Parent][OnMaybeDequeueOne] Error: Channel closing: too late to send/recv, messages will be lost
10:36:46     INFO -  TEST-INFO | Main app process: exit status c0000005
10:36:46  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/composer/test/test_bug434998.xul | application terminated with exit code 3221225477
10:36:46     INFO -  INFO | runtests.py | Application ran for: 0:08:34.519000
10:36:46     INFO -  INFO | zombiecheck | Reading PID log: c:\users\cltbld\appdata\local\temp\tmpa2oartpidlog
10:36:46     INFO -  ==> process 2192 launched child process 2460 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.ba7f900.860297949 -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" tab)
10:36:46     INFO -  ==> process 2192 launched child process 2488 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.1f53ea00.920155388 -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" tab)
10:36:46     INFO -  ==> process 2192 launched child process 3932 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af1e8a0.671430593 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 3348 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af204c0.853164768 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 1528 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.bde4a60.1260822411 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 1516 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.f606100.706549309 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 4032 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.f606460.1777319654 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 444 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af1fce0.333065373 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 3592 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.8c575e0.717595720 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 1144 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af1ed20.679220657 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 1008 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af20040.1669430859 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 3908 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af7dd60.1238417617 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:46     INFO -  ==> process 2192 launched child process 1320 ("C:\slave\test\build\application\firefox\plugin-container.exe" --channel=2192.af7dd60.1129106423 "c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\plugins\nptest.dll" -greomni "C:\slave\test\build\application\firefox\omni.ja" -appomni "C:\slave\test\build\application\firefox\browser\omni.ja" -appdir "C:\slave\test\build\application\firefox\browser" - 2192 "\\.\pipe\gecko-crash-server-pipe.2192" plugin)
10:36:56  WARNING -  PROCESS-CRASH | chrome://mochitests/content/chrome/editor/composer/test/test_bug434998.xul | application crashed [@ mozilla::ipc::ThreadLink::~ThreadLink()]
10:36:56     INFO -  Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpmkwi3z.mozrunner\minidumps\6f49a913-be3f-4d01-913e-460ed4538759.dmp
10:36:56     INFO -  Operating system: Windows NT
10:36:56     INFO -                    6.1.7601 Service Pack 1
10:36:56     INFO -  CPU: x86
10:36:56     INFO -       GenuineIntel family 6 model 30 stepping 5
10:36:56     INFO -       8 CPUs
10:36:56     INFO -  Crash reason:  EXCEPTION_ACCESS_VIOLATION_WRITE
10:36:56     INFO -  Crash address: 0x8
10:36:56     INFO -  Thread 102 (crashed)
10:36:56     INFO -   0  xul.dll!mozilla::ipc::ThreadLink::~ThreadLink() [MessageLink.cpp:265a7db19092 : 208 + 0x3]
10:36:56     INFO -      eip = 0x65250a00   esp = 0x3d42fa34   ebp = 0x3d42fa3c   ebx = 0x00000000
10:36:56     INFO -      esi = 0x208c6d50   edi = 0x1c6a8fb0   eax = 0x00000000   ecx = 0x208c6d50
10:36:56     INFO -      edx = 0x00000000   efl = 0x00010202
10:36:56     INFO -      Found by: given as instruction pointer in context
10:36:56     INFO -   1  xul.dll!mozilla::ipc::ThreadLink::`scalar deleting destructor'(unsigned int) + 0xa
10:36:56     INFO -      eip = 0x65252d41   esp = 0x3d42fa38   ebp = 0x3d42fa3c
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   2  xul.dll!mozilla::ipc::MessageChannel::Clear() [MessageChannel.cpp:265a7db19092 : 280 + 0x11]
10:36:56     INFO -      eip = 0x6525ae87   esp = 0x3d42fa44   ebp = 0x3d42fa64
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   3  xul.dll!mozilla::ipc::MessageChannel::Close() [MessageChannel.cpp:265a7db19092 : 1683 + 0x6]
10:36:56     INFO -      eip = 0x6525bcbd   esp = 0x3d42fa58   ebp = 0x3d42fa64
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   4  xul.dll!`anonymous namespace'::ChildImpl::ThreadLocalDestructor(void *) [BackgroundImpl.cpp:265a7db19092 : 424 + 0xd]
10:36:56     INFO -      eip = 0x6525b3bf   esp = 0x3d42fa6c   ebp = 0x3d42fa74
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   5  nss3.dll!PR_SetThreadPrivate [prtpd.c:265a7db19092 : 180 + 0x5]
10:36:56     INFO -      eip = 0x683a5c87   esp = 0x3d42fa7c   ebp = 0x3d42fa8c
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   6  xul.dll!`anonymous namespace'::ChildImpl::CloseForCurrentThread() [BackgroundImpl.cpp:265a7db19092 : 1703 + 0xd]
10:36:56     INFO -      eip = 0x652546d5   esp = 0x3d42fa94   ebp = 0x3d42fbec
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   7  xul.dll!`anonymous namespace'::WorkerThreadPrimaryRunnable::Run() [RuntimeService.cpp:265a7db19092 : 2697 + 0x4]
10:36:56     INFO -      eip = 0x65f71b3a   esp = 0x3d42faa0   ebp = 0x3d42fbec
10:36:56     INFO -      Found by: call frame info
10:36:56     INFO -   8  xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:265a7db19092 : 766 + 0xd]
10:36:56     INFO -      eip = 0x6500e23e   esp = 0x3d42fbf4   ebp = 0x3d42fc50
10:36:56     INFO -      Found by: call frame info
Comment hidden (Treeherder Robot)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1032783
You need to log in before you can comment on or make changes to this bug.