If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Sora][WAP Push]HU: WAP push messages arrive but the URL cannot be copied

RESOLVED DUPLICATE of bug 747798

Status

Firefox OS
Gaia::Wappush
P1
normal
RESOLVED DUPLICATE of bug 747798
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Firefox OS v1.3
 AU_LINUX_GECKO_B2G_JB_3.2.01.03.00.112.301
 Mozilla build ID:20140422024003
 
 DEFECT DESCRIPTION:
 WAP push messages arrive but the URL cannot be copied or opened thus it does not make sense to use push messages on this handset.
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Component: Gaia::SMS → Gaia::Wappush
(In reply to sync-1 from comment #0)
>  WAP push messages arrive but the URL cannot be copied or opened thus it
> does not make sense to use push messages on this handset.

We currently don't have support for copy/paste but tapping the URL in a WAP Push message opens the browser. Can you check that this is the case? If the URL cannot be opened anymore then we might have regressed something.
Flags: needinfo?(sync-1)

Comment 2

3 years ago
(In reply to Gabriele Svelto [:gsvelto] from comment #1)
> (In reply to sync-1 from comment #0)
> >  WAP push messages arrive but the URL cannot be copied or opened thus it
> > does not make sense to use push messages on this handset.
> 
> We currently don't have support for copy/paste but tapping the URL in a WAP
> Push message opens the browser. Can you check that this is the case? If the
> URL cannot be opened anymore then we might have regressed something.

Yes, url can be opened, but can't be copied.
(Reporter)

Updated

3 years ago
Flags: needinfo?(sync-1)

Comment 3

3 years ago
But the copy of url is still our customer's request.
Dear tianm,

In the description, you wrote:

 WAP push messages arrive but the URL cannot be copied or opened thus it does not make sense to use push messages on this handset.


Now I understand that the "opened" case works?
Flags: needinfo?(tianm)

Comment 5

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Dear tianm,
> 
> In the description, you wrote:
> 
>  WAP push messages arrive but the URL cannot be copied or opened thus it
> does not make sense to use push messages on this handset.
> 
> 
> Now I understand that the "opened" case works?

Yes, it can works.
Flags: needinfo?(tianm)
Ok; then we don't support copy/paste at all on the whole platform. Therefore I think we should either dupe this bug to the bug about copy/paste or close it.

What do you think Gabriele?
Definitely a DUP of bug 747798.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747798
You need to log in before you can comment on or make changes to this bug.