Closed Bug 1033112 Opened 10 years ago Closed 10 years ago

mozpool-dbcron crontask was parsed by cron before 'apache' user existed

Categories

(Infrastructure & Operations :: RelOps: Puppet, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dustin, Assigned: dustin)

Details

(Whiteboard: [time=0:30])

Attachments

(1 file)

cron promptly gave up on the crontask forever.  Well, I think it did.

[root@mobile-imaging-001.p1.releng.scl3.mozilla.com ~]# cat /etc/cron.d/mozpool-dbcron
0 0 * * * apache /opt/mozpool/dbcron.sh
[root@mobile-imaging-001.p1.releng.scl3.mozilla.com ~]# grep dbcron /var/log/cron
Jul  1 15:04:01 mobile-imaging-001 crond[4144]: (CRON) bad username (/etc/cron.d/mozpool-dbcron)

anyway, that crontab file should depend on Class['packages::httpd'], I think.
I'll also verify the "I think" part and let atoll know, since we discussed it briefly in irc.
Whiteboard: [time=0:30]
Confirmed with a simple experiment.
Attached patch bug1033112.patchSplinter Review
Attachment #8479913 - Flags: review?(jwatkins)
Attachment #8479913 - Flags: review?(jwatkins) → review+
Attachment #8479913 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: