[Dolphin Only]Front/rear camera, flash light, and option buttons sometimes cannot be invoked successfully.

RESOLVED WORKSFORME
(Needinfo from 2 people)

Status

Firefox OS
Gaia::Camera
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: mlien, Assigned: mikeh, NeedInfo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 affected, b2g-v2.0 wontfix)

Details

(Whiteboard: [1.4-dolphin-test-run-1])

(Reporter)

Description

4 years ago
[Device]
  Dolphin
---------------------------------------------
[Reproduction build] - 0530pac + pvt gaia+gecko
  Gaia      bf5ad311b6a14383924d6a3898c650ffa4525840
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/6817b6858ccf
  BuildID   20140701160201
  Version   30.0
  ro.build.version.incremental=84
  ro.build.date=Fri Jun 27 08:53:28 CST 2014

---------------------------------------------
[Reproduce Steps]
  1. Launch Camera app
  2. Invoke Front/rear camera, flash light, or option buttons
---------------------------------------------
[Expected Result]
  Can be invoked every time
---------------------------------------------
[Actual Result]
  Sometimes it cannot be invoked successfully
  Please refer to the result video:
    - https://www.youtube.com/watch?v=TsFO4IlezE8&feature=youtu.be
---------------------------------------------
[Reproduce Rate]
  70%
Mike - With any particular blocking nomination, I think you need to make sure to do a branch check & a device check - that means you should be checking to see if the bug reproduces on 1.4 Flame & 1.3 Flame before nominating the bug.
Flags: needinfo?(mlien)
(Reporter)

Comment 2

4 years ago
(In reply to Jason Smith [:jsmith] from comment #1)
> Mike - With any particular blocking nomination, I think you need to make
> sure to do a branch check & a device check - that means you should be
> checking to see if the bug reproduces on 1.4 Flame & 1.3 Flame before
> nominating the bug.

I may lost my whole test results with other verification and comparison.
On Flame v1.4(base image v122) and Buri v1.4, top buttons can be invoked normally and immediately every time.
Flags: needinfo?(mlien)

Comment 3

4 years ago
What is the way forward if we can only reproduce the issue on dolphin?
This should issue should be fixed, really horrible user experience
Flags: needinfo?(jsmith)
Flags: needinfo?(dmarcos)
(In reply to Sri Kasetti from comment #3)
> What is the way forward if we can only reproduce the issue on dolphin?
> This should issue should be fixed, really horrible user experience

We probably should block on this for 1.4.

Note - The one thing that would be worth finding out is if this is a vendor bug in Dolphin or a Kitkat bug. We'll need our partner to weigh in to determine if it's a vendor bug or not.
Flags: needinfo?(jsmith)
James,

can someone from your side also check this? because we do not see the same problem on flame according to comments.
Flags: needinfo?(james.zhang)
Flags: needinfo?(ying.xu)
Flags: needinfo?(james.zhang)
Flags: needinfo?(Dafeng.Xu)
status-b2g-v1.4: --- → affected
Flags: needinfo?(siiaceon.cao)

Comment 7

4 years ago
I'd tried to revert the patch of bug 988704 and it could improve the response of pressing buttons in Camera app. 

For this, I have to add more explanations to clarify.

1.The patch of bug 988704 intends to solve the preview performance. Actually after the landing of the patch, the performance of camera preview improve gracefully. 

2. In the current code base, This patch seems causes the response time of pressing buttons in Camera app. After reverting it, the response time of pressing buttons is improved and we also don't preview performance issue the device originally had. For the issue happens on bug 988704, it seems there exists other fix to solve it so the patch landed for bug 988704 becomes invalid.

Hi Sotaro,

When I went through the Android code, I could see MIN_UNDEQUEUED_BUFFERS(4) in class SurfaceMediaSource. But even so, I didn't see any native code using this value. In fact, using MIN_UNDEQUEUED_BUFFERS(2) defined in BufferQueue.h instead. May I confirm with you about what I saw?
May I have your opinion about issues we encountered? Thanks.
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Vincent Liu[:vliu] from comment #7)
> 
> Hi Sotaro,
> 
> When I went through the Android code, I could see MIN_UNDEQUEUED_BUFFERS(4)
> in class SurfaceMediaSource. But even so, I didn't see any native code using
> this value. In fact, using MIN_UNDEQUEUED_BUFFERS(2) defined in
> BufferQueue.h instead. May I confirm with you about what I saw?
> May I have your opinion about issues we encountered? Thanks.

"4" is directly set at SurfaceMediaSource::SurfaceMediaSource() like the following.

> mMaxAcquiredBufferCount(4),  // XXX double-check the default

http://androidxref.com/4.4.3_r1.1/xref/frameworks/av/media/libstagefright/SurfaceMediaSource.cpp#49
Flags: needinfo?(sotaro.ikeda.g)
> 
> 2. In the current code base, This patch seems causes the response time of
> pressing buttons in Camera app. After reverting it, the response time of
> pressing buttons is improved and we also don't preview performance issue the
> device originally had. For the issue happens on bug 988704, it seems there
> exists other fix to solve it so the patch landed for bug 988704 becomes
> invalid.

I quickly checked about fps on latest master flame. When MIN_UNDEQUEUED_BUFFERS is changed to "2", the camera preview was not good enough, though it seems better than before.
- camera preview for taking picutre, intermittently fps drop to 14 fps.
- camera preview during video recording was 17fps
Running the following version on Dolphin, I am unable to reproduce. Also, I noticed in your video that it took an unusually long time for the viewfinder preview to come up (the spinner stayed on screen for a while). On my Dolphin, the spinner spun around maybe 2-3 times and the viewfinder came up.

Gaia      5c9e1e4131d3ac8915ed88b72bb66dc7d97be6a0
Gecko     b65bf5742c9534d3f0ff64f6cfc1913fabfa4c26
BuildID   20140707085034
Version   30.0
ro.build.version.incremental=83
ro.build.date=Thu Jun 26 08:52:43 CST 2014

Comment 11

4 years ago
This is the blocker according to its symptom.
blocking-b2g: 1.4? → 1.4+

Updated

4 years ago
Duplicate of this bug: 1034033

Comment 13

4 years ago
Mike is helping investigate to identify the issue with dolphin.
Assignee: nobody → mhabicher
Summary: [Dolphin]Front/rear camera, flash light, and option buttons sometimes cannot be invoked successfully. → [Dolphin Only]Front/rear camera, flash light, and option buttons sometimes cannot be invoked successfully.
I just tried to reproduce this on:
- gecko: b2g-inbound:bff799535eb7
- gaia: master:ca0bca3adc71de63df8de77cfa58fcbf87a0fbfb

Observed:
- camera starts up (relatively) quickly, no spinner
- all UI elements are responsive
- both front and back cameras successfully take pictures and record video
I have also tried to reproduce this one:
- gecko: b2g30_v1_4:1b9cee26ddf9
- gaia: v1.4:229864ff4ad90899f017341b9e81ed0b53498c66

As with master/b2g-inbound in comment 14, the Camera app works properly.
(In reply to Mike Habicher [:mikeh] from comment #15)

> As with master/b2g-inbound in comment 14, the Camera app works properly.

(Though the Camera app does take long enough to start up that the UI shows the spinner.)
Tested:
- gecko: aurora:558d378d7364
- gaia: v2.0:16d99f67c376378df850343667cee43af87c24a6

Observed:
- correct behaviour of all aspects of Camera app.

The only thing I haven't checked is the Gonk version. Comment 0 mentions 0530pac--is there some way to check my Gonk version? ro.build.id says [KOT49H].
Flags: needinfo?(mlien)
(Reporter)

Comment 18

4 years ago
you can refer to https://intranet.mozilla.org/B2G_Team/Dolphin#Required_Files
about gonk version, you can get from "adb shell getprop ro.build.version.incremental"
ro.build.id from all Dolphin builds are the same

I verify again with the latest build: 7/7pac + pvt gaia/gecko
Gaia      b0e9b4bdb39c5eb93a6783a34624ffc84f62b126
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/acf704e54e19
BuildID   20140709000201
Version   30.0
ro.build.version.incremental=272
ro.build.date=Mon Jul  7 14:44:46 CST 2014

touch response seems much better than before
Flags: needinfo?(mlien)
(In reply to Mike Lien[:mlien] from comment #18)

> touch response seems much better than before

If there's nothing else to go on, can we close this issue?
Flags: needinfo?(mlien)
(Reporter)

Comment 20

4 years ago
mark it as worksforme, if it happens in the future, we can reopen it and keep tracking
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mlien)
Resolution: --- → WORKSFORME
Given this is dolphin device specific, i am marking 2.0 as wontfix at this point.
status-b2g-v2.0: --- → wontfix

Updated

4 years ago
Whiteboard: [1.4-dolphin-test-run-1]
Flags: needinfo?(dmarcos)

Updated

4 years ago
Flags: needinfo?(ying.xu)
You need to log in before you can comment on or make changes to this bug.