[Vertical Homescreen] Intermittent MarionetteJS failure on Travis: 1) Vertical - Collection create collection shows message when offline: NoSuchElement: (7) Unable to locate element: .modal-dialog-alert

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: julienw, Assigned: kgrandon)

Tracking

({intermittent-failure})

unspecified
2.0 S5 (4july)
x86_64
Linux
intermittent-failure

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
daleharvey
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
1) Vertical - Collection create collection shows message when offline:

NoSuchElement: (7) Unable to locate element: .modal-dialog-alert

Remote Stack:

<none>

at Error.MarionetteError (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)

at Object.Client._handleCallback (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)

at /home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21

at TcpSync.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:100:10)

at Object.send (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)

at Object.Client._sendCommand (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)

at Object._findElement (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1303:19)

at Object.findElement (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:1352:32)

at /home/travis/build/mozilla-b2g/gaia/apps/verticalhome/test/marionette/collection_test.js:155:12

at modifiedTest (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:646:22)

at Object.Client.waitForSync (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:671:9)

at Object.Client.waitFor (/home/travis/build/mozilla-b2g/gaia/node_modules/marionette-client/lib/marionette/client.js:650:60)

at Context.<anonymous> (/home/travis/build/mozilla-b2g/gaia/apps/verticalhome/test/marionette/collection_test.js:153:12)


https://travis-ci.org/mozilla-b2g/gaia/jobs/28912085
(Reporter)

Updated

4 years ago
See Also: → bug 1033223
Kevin: Could you prioritize this accordingly in your team?
Flags: needinfo?(kgrandon)
(Assignee)

Comment 2

4 years ago
Created attachment 8449512 [details] [review]
Github pull request
Flags: needinfo?(kgrandon)
(Assignee)

Comment 3

4 years ago
I am testing this on my local travis instance here: https://travis-ci.org/mozilla-b2g/gaia/builds/28978821
(Assignee)

Comment 4

4 years ago
(In reply to Kevin Grandon :kgrandon from comment #3)
> I am testing this on my local travis instance here:
> https://travis-ci.org/mozilla-b2g/gaia/builds/28978821

Oops, used the wrong target. Proper local run is: https://travis-ci.org/KevinGrandon/gaia/builds/28982864
(Assignee)

Updated

4 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S5 (4july)
(Assignee)

Comment 5

4 years ago
Created attachment 8449922 [details] [review]
Github pull request

Ok, think I finally have this one solved. The problem is that we were firing off the 'offline' event before the listener was added. I've added a body data attribute to inform the test when it's ready as there's no good elements to listen for in this case.

Dale - could you give this one a look if you have time? Thanks!
Attachment #8449922 - Flags: review?(dale)
Comment on attachment 8449922 [details] [review]
Github pull request

This look good to me, cheers
Attachment #8449922 - Flags: review?(dale) → review+
(Assignee)

Updated

4 years ago
Attachment #8449512 - Attachment is obsolete: true
(Assignee)

Comment 7

4 years ago
Master: https://github.com/mozilla-b2g/gaia/commit/5b8def74f2b90b100cde80b8c5ff4cf7bca04e6d
2.0: (a=test only) https://github.com/mozilla-b2g/gaia/commit/7fc473d9644efc37ea95a60f034c931d9aff89f1
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.