Weirdness when tracking a scrollbar thumb

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Pierre Saslawsky, Assigned: jag (Peter Annema))

Tracking

Trunk
Future
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Checked with a recent debug build on the Mac.  Did not test other platforms.
- Open 2 windows and put them a bit apart on the screen
- Go to any page that displays a vertical scrollbar
- Click the scrollbar thumb on the front window and, keeping the button clicked,
move the mouse up and down on both sides of the scrollbar of the front window
and on both sides of the scrollbar of the background window (or on both sides of
the right edge of the background window if the background window doesn't have a
scrollbar).
===> The thumb tracks the mouse when the mouse is near the scrollbar of the
backround window.

See the attached picture: the zones in red show the places where the thumb
tracks the mouse.  The bug seems a bit trivial as it is, but I was wonderering
if other events were not spilling over windows too.
(Reporter)

Comment 1

17 years ago
Created attachment 52237 [details]
see how the bug works...
(Reporter)

Updated

17 years ago
Summary: Weirdeness when tracking a scrollbar thumb → Weirdness when tracking a scrollbar thumb

Comment 2

17 years ago
Might be a dup of bug 46347.
(Reporter)

Comment 3

17 years ago
*** Bug 46347 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 4

16 years ago
--> default owner
Assignee: hyatt → jaggernaut
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0.1 → ---

Updated

16 years ago
Target Milestone: --- → Future

Comment 5

16 years ago
Mozilla Mach-O 20030211 does not exhibit this behavior, and
Mozilla CFM build is dead.
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.