Give the watched repo tabs a link target, so they can be opened in a new tab

RESOLVED DUPLICATE of bug 1125352

Status

Tree Management
Treeherder
P3
normal
RESOLVED DUPLICATE of bug 1125352
4 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({regression})

Details

(Reporter)

Description

4 years ago
Watched/pinned repos appear on the tab strip at the top of the UI, similar to the MRU list of repos in TBPL.

A common TBPL workflow for me, is to spawn another TBPL tab (opened directly at the desired repo) by middle mouse clicking the repo name in the MRU list at the top of the TBPL UI. In treeherder the equivalent of this is the watched repo tab strip - so it would be good if those had a link target set, to allow easy jumping to another repo in a new tab.

I guess this partly depends on the outcome of bug 1032220.
(Reporter)

Updated

3 years ago
Priority: P2 → P3
We could add another button to the watched repo to "open in a new tab" button.
Assignee: nobody → cdawson
Status: NEW → ASSIGNED
(Reporter)

Comment 2

3 years ago
Could we just set a link target so middle click and the context menu work, but left click interacts with the UI as at present? Adding another button will take up more screen estate.
(Reporter)

Updated

3 years ago
Blocks: 1032220
No longer depends on: 1032220
(Reporter)

Updated

3 years ago
Blocks: 1059400
No longer blocks: 1030636
(Reporter)

Updated

3 years ago
No longer blocks: 1059400
Keywords: regression
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1116874
(Reporter)

Comment 4

3 years ago
Let's fix this as part of bug 1125352.
Assignee: cdawson → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125352
You need to log in before you can comment on or make changes to this bug.