If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow Mozillians to update their legacy vouch by re-vouching

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: giorgos, Assigned: tasos)

Tracking

2014-07.3

Details

(Whiteboard: [kb=1429213] [vouching rel. 1])

(Reporter)

Description

3 years ago
The vouch authorization migration scripts move all the current vouches to the new system, preserving voucher, vouchee and date_vouched (when applicable). (bug 997425)

These migrated vouches are called "Legacy vouches" and will be deleted in 60 days from prod deployment. (bug 1033305)

We need to allow Mozillians to update their vouches by allowing Mozillian A to vouch Mozillian B when Mozillian B has a legacy vouch from Mozillian A.

In this case we:
 * Update Vouch.description with the reasoning provided by Mozillian A
 * Update Vouch.date_vouched if date_vouched == None (that applies to some vouches)
(Reporter)

Updated

3 years ago
Whiteboard: [kb=1429213]

Comment 1

3 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/a246dcbbe2e355b04928ea7aacc3d1561972e95d
[fix bug 1033306] Allow Mozillians to update their legacy vouch by re-vouching.

https://github.com/mozilla/mozillians/commit/54d1b31a39b511ca19c028715a59a3cddd6b1720
Merge pull request #1014 from akatsoulas/1033306

 [fix bug 1033306] Allow Mozillians to update their legacy vouch by re-vouching.

Updated

3 years ago
Version: other → next

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
Whiteboard: [kb=1429213] → [kb=1429213] [vouching rel. 1]
(Reporter)

Comment 2

3 years ago
Minimum verification steps:
 1. Go to your profile page
 2. Select one of your vouchees from the list and visit profile page of vouchee
 3. Vouchee should have a vouch from you with reason "Legacy Vouch"
 4. You should see the vouch form
 5. Submit the vouch form
 6. Your vouch should now be updated, i.e. reasoning should display the reasoning you provided in the form
 7. You shouldn't see the vouch form anymore
I cannot verify this one. Verification steps:

* I visit my profile.
* Select one of my vouchees from the list.
* Vouchee has a Legacy Vouch by me.
* No vouch form is rendered.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The vouchee profile is the following:
https://mozillians.allizom.org/en-US/u/theterabyte/
It turned out the problem is that I had removed my vouches.
Verified now in stage.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
Version: next → 2014-07.3
You need to log in before you can comment on or make changes to this bug.