Fix talos g1 on Windows and Mac OSX

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cbook, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

We have perma failing tests on all integration trees on OSX and Windows for talos g1 like

https://tbpl.mozilla.org/php/getParsedLog.php?id=42926423&tree=B2g-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=42916791&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=42929688&tree=Mozilla-Inbound

hiding this tests for this platforms on m-c, m-i,fx-team and b2g-inbound
Blocks: 1033332
also hidden on aurora now
Depends on: 1035193
They're green now:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&jobname=g1&showall=1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
(In reply to Carsten Book [:Tomcat] from comment #0)
> We have perma failing tests on all integration trees on OSX and Windows for
> talos g1 like

2014-07-02 is about the time where g1 was added. So it's important to say that apparently it never worked correctly on OSX and Windows.

Since I wrote both the g1 tests (tp5o_scroll and glterrain), I wish someone would have pinged me about these failures.

Regardless, all the sample logs from comment 0 are gone now, and I think it's important to understand what failed.

There's another g1 issue with bug 1037619 which affects linux (intermittent errors).

I can't tell if they're related or not, but bug 1037619 is most probably automation issues where the slave doesn't get fully updated before the test starts.
You need to log in before you can comment on or make changes to this bug.