[v2.0] Fix test_homescreen_move_app.py failure

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RobertC, Assigned: RobertC)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
zcampbell
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
Test is failing on Jenkins because it doesn't see any apps on the homescreen.
The error is not reproduced manually. It looks like an issue with the test.

Build info:
Gaia      3bfe47c58c959c42f5ffe0309b5380ea514ccd69
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f40e767ea283
BuildID   20140702000201
Version   32.0a2
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014


Traceback (most recent call last):
File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.smoketest/.env/local/lib/python2.7/site-packages/marionette_client-0.7.10-py2.7.egg/marionette/marionette_test.py", line 170, in run
testMethod()
File "/var/jenkins/workspace/b2g.flame.mozilla-aurora.ui.smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/homescreen/test_homescreen_move_app.py", line 23, in test_move_app_position
first_app_before_move = self.homescreen.visible_apps[0].name
IndexError: list index out of range

http://selenium.qa.mtv2.mozilla.com:8080/view/B2G%20Aurora/job/b2g.flame.mozilla-aurora.ui.smoketest/50/HTML_Report/
(Assignee)

Comment 1

4 years ago
Created attachment 8449379 [details] [review]
Pull request master
Attachment #8449379 - Flags: review?(zcampbell)
Attachment #8449379 - Flags: review?(florin.strugariu)
(Assignee)

Comment 2

4 years ago
Created attachment 8449381 [details] [review]
Pull request v2.0

Ran an adhoc with the changes on v2.0
http://selenium.qa.mtv2.mozilla.com:8080/job/b2g.flame.mozilla-aurora.ui.adhoc/14/console
Attachment #8449381 - Flags: review?(zcampbell)
Attachment #8449381 - Flags: review?(florin.strugariu)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1029276

Comment 4

4 years ago
Comment on attachment 8449379 [details] [review]
Pull request master

r+ but let's make the default value to be at least 1.
Attachment #8449379 - Flags: review?(zcampbell) → review+

Updated

4 years ago
Attachment #8449379 - Flags: review?(florin.strugariu)

Updated

4 years ago
Attachment #8449381 - Attachment is obsolete: true
Attachment #8449381 - Flags: review?(zcampbell)
Attachment #8449381 - Flags: review?(florin.strugariu)
You need to log in before you can comment on or make changes to this bug.