html input number spinners not working properly when initial value is empty and min/max are set

RESOLVED DUPLICATE of bug 1028712

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 1028712
4 years ago
3 years ago

People

(Reporter: trungbkk, Unassigned)

Tracking

({html5, testcase})

30 Branch
html5, testcase
Points:
---

Firefox Tracking Flags

(firefox30 affected, firefox31 affected, firefox32 affected, firefox33 affected)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Create an input type number with a min/max value <input type="number" min="10" max="20" >


Actual results:

If we click on arrow up or down when the value is empty, the first number that appears is 1 and we cannot click the arrow up or down anymore.


Expected results:

The behaviour should be like Google Chrome :
- if the initial value is empty, click up or down will display min=10
- if the initial value is <min, the final value is min=10
- if the initial value is >max, the final value is max=20
- if the initial value is in the range, the final value is increased or decreased depends on the arrow
(Reporter)

Updated

4 years ago
Version: 33 Branch → 30 Branch
(Reporter)

Updated

4 years ago
Component: Untriaged → General
Keywords: html5

Updated

4 years ago
Status: UNCONFIRMED → NEW
status-firefox30: --- → affected
status-firefox31: --- → affected
status-firefox32: --- → affected
status-firefox33: --- → affected
Component: General → DOM: Core & HTML
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Product: Firefox → Core
Hardware: x86 → All

Updated

4 years ago
Blocks: 344616
Flags: needinfo?(jwatt)
Summary: html input number not working properly → html input number spinners not working properly when initial value is empty and min/max are set
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028712
Clearing old needinfo.
Flags: needinfo?(jwatt)
You need to log in before you can comment on or make changes to this bug.