Closed Bug 1033465 Opened 6 years ago Closed 6 years ago

[Vertical Homescreen] Cant add pinned sites to a smart collection

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- fixed

People

(Reporter: sfoster, Assigned: kgrandon)

References

Details

(Whiteboard: [2.0-VH-bug-bash][systemsfe])

Attachments

(4 files)

STR: 
1. Long tap on any icon on the vertical homescreen
2. Drag an icon onto a smart collection. It should have a green plus next to it. The icon is *not* removed from the homescreen but does appear now in the collection if you click 'Done' to exit edit mode and tap the smart collection to see its contents
3. Repeat steps 1,2. It appears successful, but the 2nd icon does not show up in the collection

Nothing in logcat that seems relevant.
I am not able to repro. I tried to drop packaged apps and hosted apps into pre-installed, standard and custom smart collections. 

With what icons have you tried?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Summary: Can only add one icon to a smart collection → [Vertical Homescreen] Can only add one icon to a smart collection
Whiteboard: [2.0-VH-bug-bash][systemsfe]
:jlorenzo, yeah I can't make it happen again now :( Before I had reproduced using a built-in collection and a new custom one, seemingly with adding any arbitrary icons.
Ah, looks like you just can't add pinned websites to smart collections: 

Updated STR: 
* In the browser app, pin a site to the homescreen using the start icon
* On the homescreen, long-tap on the icon created for the pinned site to enter edit mode
* Drag that icon onto a smart collection icon

Results: 
* The pinned site's favicon shows up in the smart collection composite icon
* If you open the collection, the pinned site is not there

Expected results: 
* The pinned site is visible when you open the collection
Summary: [Vertical Homescreen] Can only add one icon to a smart collection → [Vertical Homescreen] Cant add pinned sites to a smart collection
Component: Gaia::Homescreen → Gaia::Everything.me
Can we confirm this was working with the old 1.4 e.me implementation?
Keywords: qawanted
Blocks: 1015336
I am reproducing it on 2.0, but not on 1.4. Blocker.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
Can repro. Thanks for filing!
blocking-b2g: 2.0? → 2.0+
Keywords: qawanted
Taking.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S5 (4july)
Attached file Github pull request
Working on a test.
Comment on attachment 8449675 [details] [review]
Github pull request

Cristian - could you by chance help me review this patch? The actual patch is only a few lines long (just waiting for bookmarks datastore in the collections app), but most of the code is for the integration test. Thanks!
Attachment #8449675 - Flags: review?(crdlc)
Duplicate of this bug: 1033594
Blocks: 1033546
Comment on attachment 8449675 [details] [review]
Github pull request

LGTM, good job as usual, thanks a lot for this. Please review the jshint before landing.
Attachment #8449675 - Flags: review?(crdlc) → review+
Thanks for the review!

Master: https://github.com/mozilla-b2g/gaia/commit/d813860f012e653df96f7b1a02dd28f962f46630
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This issue has been failed verified on Flame 2.1.
See attachment: verify_v2.1.MP4 and logcat_v2.1_1150.txt
Reproducing rate: 5/8

STR: 
1.Open browser app and open a website.
2.Add the website to homescreen.
3.On the homescreen, long-tap on the website icon to enter edit mode.
4.Drag the website icon on some smart collection icon(such as Music\Movies\Games) but not add into these smart collection, and then drag it to a nearby location. 
5.Drag the website icon into a smart collection.
6.Tap Done and open the smart collection.
**The website icon is not in the smart collection.
7.Drag the website icon onto a smart collection again.
8.Tap Done and open the smart collection again.
**The website icon is in the smart collection.
Note:It doesn't exist on Flame v2.0.

Flame 2.1 build:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141205.035305
FW-Date         Fri Dec  5 03:53:16 EST 2014
Bootloader      L1TC00011880


This issue has been successfully verified on Flame 2.0.
See attachment: verified_v2.0.mp4
Reproducing rate: 0/5.

STR:
1.Open a website in Browser app.
2.Add the website to homescreen.
3.On the homescreen, long-tap on the website icon to enter edit mode.
4.Drag the website icon onto a smart collection icon.
**The website icon is in the smart collection.

Flame 2.0 build:
Gaia-Rev        856863962362030174bae4e03d59c3ebbc182473
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/e40fe21e37f1
Build-ID        20141207000206
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141207.034341
FW-Date         Sun Dec  7 03:43:52 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(hlu)
I will check verification result later.
NI?whsu
Flags: needinfo?(hlu) → needinfo?(whsu)
It look like the patch doesn't work because Shally still can reproduce it.

--- -- - --- -- - --- -- - --- -- -
Hi, Shally,

May I have your help?
Please verify this patch on master, v2.1, and v2.0 to see if it still happens.
If so , please submit a new bug and note bug number here.
Many thanks.
Flags: needinfo?(whsu) → needinfo?(lixia)
(In reply to William Hsu [:whsu] from comment #19)
> Hi, Shally,
> 
> May I have your help?
> Please verify this patch on master, v2.1, and v2.0 to see if it still
> happens.
> If so , please submit a new bug and note bug number here.
> Many thanks.

Hi William,
 
    I can repro this bug sometimes,I will create a new bug and note the bug number tomorrow.
Flags: needinfo?(lixia)
See Also: → 1119656
NI William
Flags: needinfo?(whsu)
Hi William,

    I can repro this bug on Flame v2.1,but can't repro on Flame 2.0&2.2.Please see new bug 1119656.
(In reply to Shally from comment #22)
> Hi William,
> 
>     I can repro this bug on Flame v2.1,but can't repro on Flame
> 2.0&2.2. Please see new bug 1119656.

Hi, Shally,

Good Job!
Thank you very much! :)
Flags: needinfo?(whsu)
You need to log in before you can comment on or make changes to this bug.