Closed Bug 1033501 Opened 5 years ago Closed 4 years ago

Dragging the icon in a one-icon group at the bottom of the home-screen downwards introduces an unnecessary extra divider

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: cwiiis, Unassigned)

References

()

Details

(Whiteboard: [2.0-VH-bug-bash])

Attachments

(1 file)

If your last group only has a single icon, dragging that icon downwards adds an extra divider that if you let go of the icon will immediately be removed.
Is it a blocker from a UX perspective?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Flags: needinfo?(jsavory)
Whiteboard: [2.0-VH-bug-bash]
We need a video of the bug here.
Blocks: 1015336
Keywords: qawanted
Video Link
http://youtu.be/G4vw9BpCOxA

Environmental Variables
Device: Flame 2.1 Master
Build ID: 20140702100721
Gecko: https://hg.mozilla.org/mozilla-central/rev/36a5f54bd12b
Gaia: b0ddb2122771e25cdd880359406a53b10cdc0507
Platform Version: 33.0a1
Firmware Version: V122
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?][QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking?]
Flags: needinfo?(jmitchell)
Attempting to repro this issue caused my devices Vertical Homescreen to become unresponsive. Not writing up a new issue because it looks to be an extension of this issue (hit it reproducing this issue). 

Video: http://youtu.be/NVrKNQHXa-U

(Attaching Logcat as well)


Flame Master
BuildID: 20140701040201
Gaia: 90bb898e8401f5fb98edcf38293073c5c26ab7bd
Gecko: 83c09fe3a658
Version: 33.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
Flags: needinfo?(jmitchell)
QA Contact: ekramer
Flags: needinfo?(jmitchell)
(In reply to Eric Kramer (Kramer) from comment #4)
> Created attachment 8449854 [details]
> Logcat_Vertical-Homescreen-unresponsive
> 
> Attempting to repro this issue caused my devices Vertical Homescreen to
> become unresponsive. Not writing up a new issue because it looks to be an
> extension of this issue (hit it reproducing this issue). 
> 
> Video: http://youtu.be/NVrKNQHXa-U
> 
> (Attaching Logcat as well)
> 
> 
> Flame Master
> BuildID: 20140701040201
> Gaia: 90bb898e8401f5fb98edcf38293073c5c26ab7bd
> Gecko: 83c09fe3a658
> Version: 33.0a1 (Master) 
> Firmware Version: v122
> User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

This is a different bug - get a new bug open for this issue. Flagging QA Wanted to get a video of the bug as written.
Keywords: qawanted
Added a URL of a short video that may be this issue reproduced: http://youtu.be/qvp8s5GZVmQ
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking?] [QAnalyst-Triage?]
Flags: needinfo?(jsavory)
Flags: needinfo?(jmitchell)
Flags: needinfo?
Keywords: qawanted
Accidentally removed needinfo for jsavory@mozilla.com
Flags: needinfo?(jsavory)
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] [QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking?] [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Flags: needinfo?
After the app is dropped after the bug is reproduced, does the empty divider stay around? If it does, does the empty divider disappear post phone restart?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] [QAnalyst-Triage+] → [VH-FL-blocking-][VH-FC-blocking?]
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #8)
> After the app is dropped after the bug is reproduced, does the empty divider
> stay around? If it does, does the empty divider disappear post phone restart?

After the app is dropped, the empty divider disappears (i.e. things return to the correct state) - this is only an issue during dragging.
Blocks: vertical-home-next
No longer blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking-]
Keywords: qawanted
I don't think this one should be a blocker, but it can look a bit broken when the user does see the extra divider so hopefully we can get this one fixed.
Flags: needinfo?(jsavory)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.