Closed Bug 1033536 Opened 6 years ago Closed 6 years ago

bestbuy.com shows up small and to the upper left

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WORKSFORME
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: nhirata, Unassigned)

References

()

Details

(Whiteboard: [2.0-VH-bug-bash] )

Attachments

(4 files)

Attached image 2014-07-02-11-20-53.png
Build Information
Device: Flame
Gaia      3bfe47c58c959c42f5ffe0309b5380ea514ccd69
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f40e767ea283
BuildID   20140702000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Description
as per title

Steps to Reproduce
1. add collection shopping
2. launch best buy

Expected Results
best buy shows up correctly

Actual Results
best buy web site shows small and to the upper left corner

Other Notes:
also occurs in browser going to www.bestbuy.com; looks like a gecko issue/website issue?


Reproduction Frequency: 100 %
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
This is unrelated to the vertical homescreen.

Does this reproduce on 1.4? That will determine if this is a gecko bug or a TE issue.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Keywords: qawanted
blocking-b2g: --- → backlog
Component: Gaia::Everything.me → Graphics
Product: Firefox OS → Core
Version: unspecified → 32 Branch
No repro in 1.4
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Keywords: qawantedregression
This isn't a VH bug - it's a graphics bug. We need a screenshot of this working on 1.4 as a point of comparison.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Keywords: qawanted
Whiteboard: [2.0-VH-bug-bash][systemsfe] → [2.0-VH-bug-bash]
Keywords: qawanted
Attached image 1.4 Flame (repro)
(In reply to Jason Smith [:jsmith] from comment #3)
> We need a screenshot of this working on 1.4 as a point of comparison.

Screenshot provided. This is actually NOT a regression. Issue occurs on Flame 1.4.

Device: Flame 1.4
Build ID: 20140610034016
Gaia: c39db439202b29897bee9896bc789e6782809f3a
Gecko: edd648be2b07
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Also did a quick branch check and this issue occurs on Flame 2.1 master and Buri 2.1 master.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regression
Component: Graphics → Mobile
Product: Core → Tech Evangelism
Version: 32 Branch → Trunk
Comment on attachment 8450363 [details]
Best Buy e.me bookmark - 1.4 OpenC - Screenshot

Sorry, I checked on OpenC 1.4 which has a different resolution as the Flame.
Attachment #8450363 - Attachment description: Best Buy e.me bookmark - 1.4 - Screenshot → Best Buy e.me bookmark - 1.4 OpenC - Screenshot
Re-tested on today's Flame 1.4 to make sure the results are up to date. Issue still occurs on the following environment:

Device: Flame
Build ID: 20140703061653
Gaia: 71aa8a3697e8daacdaee3d447a38ee10f13d5b54
Gecko: 1bae550358a6
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Summary: [Vertical Homescreen] [Everything.Me] Best Buy web app shows up small and to the upper left → bestbuy.com shows up small and to the upper left
Can't reproduce on my Flame (testing website in browser). UA string says Firefox 33
Changing the URL as we are correctly redirected to
http://m.bestbuy.com/m/e/digital/
And the issue is happening on this page.


I can reproduce on my Flame with 2.1 with UA string being Firefox 33.0
buildid 20140713160201

But another interesting detail. a simple small pinch, resize the page to the desired size full screen, navigating through the site fixes things too. So there is something very specific for this initial stage.

screen.width/height = 320/569
window.innerWidth/innerHeight = 980/1380
window.devicePixelRatio = 1.5



This should have no effect as it is not implemented in Firefox, if I'm correct.
09:57:10.159 Expected media feature name but found '-webkit-min-device-pixel-ratio'. w_common-min.css:4
09:57:10.159 Expected media feature name but found 'min-device-pixel-ratio'. w_common-min.css:4

@media only screen and (-webkit-min-device-pixel-ratio: 2), only screen and (min-device-pixel-ratio: 2){
	#branding,#menu-link a,#search-link a,.cart-link a,.search-submit,.search-submit-input{
		background-image:url("../images/css_sprite_retina.png");
		-moz-background-size:255px 35px;
		-o-background-size:255px 35px;
		-webkit-background-size:255px 35px;
		background-size:255px 35px;
		background-repeat:no-repeat
	}

So indeed it's strange that some of us can reproduce and others not.
Adding qawanted to see if there is a difference in between certain builds.
Keywords: qawanted
(In reply to Karl Dubost :karlcow from comment #10)
> Adding qawanted to see if there is a difference in between certain builds.

Not sure exactly what 'certain builds' here means.

There is no difference between different branches. Attaching screenshots from Flame 2.0 (left) and Flame 2.1 (right) following original STR. (There's already a 1.4 screenshot)

Screenshots taken from:

Device: Flame
BuildID: 20140807025215
Gaia: 9d681c6a3b69af2d76e7e00c31bc57e0c3efb6b9
Gecko: ca7386df2e91
Version: 32.0 (2.0)
Firmware V123
User Agent Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame
BuildID: 20140807062317
Gaia: 54c3c19d439f7dbafda5c6cc3b4850b545a068ba
Gecko: aa1617678a90
Version: 34.0a1 (2.1)
Firmware V123
User Agent Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(jmitchell)
Isn't this just a duplicate of bug 974529, getting Desktop content instead of Mobile?
Flags: needinfo?(nhirata.bugzilla)
certainly the same company, but not sure the bugs are entirely equivalent.

→ host www.bestbuy.ca
www.bestbuy.ca is an alias for www.bestbuy.ca.edgesuite.net.
www.bestbuy.ca.edgesuite.net is an alias for a1401.b.akamai.net.
a1401.b.akamai.net has address 23.3.90.106
a1401.b.akamai.net has address 23.3.90.113

→ host www.bestbuy.com
www.bestbuy.com is an alias for www.bestbuy.com.edgesuite.net.
www.bestbuy.com.edgesuite.net is an alias for a1105.b.akamai.net.
a1105.b.akamai.net has address 23.3.90.99
a1105.b.akamai.net has address 23.3.90.88


→ http --print hH --follow GET bestbuy.ca
COMMERCE-SERVER-SOFTWARE: Microsoft Commerce Server, Enterprise Edition

→ http --print hH --follow GET bestbuy.com 
Server: Apache

They seem to have slight differences in the setup.
see comment 13, please.

I believe going to www.bestbuy.com I see the mobile content and not the desktop content.  I could be mistaken.

Going to m.bestbuy.com will not show the issue.  Going to www.bestbuy.com which redirects to the m.bestbuy.com does.  If you do not clear the browser cache from going to m.bestbuy.com and go to www.bestbuy.com you will not see the issue.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(hsteen)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #14)
> I believe going to www.bestbuy.com I see the mobile content and not the
> desktop content.  I could be mistaken.


A. With Firefox OS 2.2 on a Flame device from Japan, 
1. I'm getting first a desktop screen asking me to choose my country and language on http://www.bestbuy.com/ 
2. Let's say I select United States - English. (and I do not choose Remember this location). 
3. Click on Go.
4. I indeed reach a Web site which is mobile but shrinked on Firefox OS. 
   (http://www.bestbuy.com/site/index.jsp)

B. Same steps with a Android 4.4.4 Firefox Aurora on Samsung GT-i9100
4. I get a mobile Web site which is adjusted to the size of the screen. 
   (http://www.bestbuy.com/site/index.jsp)

C. On Desktop Firefox with Fake Firefox OS UA
4. I receive a mobile site (similar to the one I received on Android) 
   (http://www.bestbuy.com/site/index.jsp)


In all cases, I'm never redirected to m.bestbuy.com

> Going to m.bestbuy.com will not show the issue.  Going to www.bestbuy.com
> which redirects to the m.bestbuy.com does.  If you do not clear the browser
> cache from going to m.bestbuy.com and go to www.bestbuy.com you will not see
> the issue.

When entering http://m.bestbuy.com/, I am being redirected http://www.bestbuy.com/
Same thing for entering http://m.bestbuy.com/m/e/digital/, redirected to http://www.bestbuy.com/
Also no issue on the simulator 2.1 (except for the starting desktop screen)

<meta name="viewport" content="width=device-width,initial-scale=1,maximum-scale=1"/>

I noticed something else on the Flame. It first shows very quickly fullscreen and then is being shrinked right away, around 2/5 of the original size of the screen.
Whiteboard: [2.0-VH-bug-bash] → [2.0-VH-bug-bash]
I get some  "international customers" splash screen that's likely completely different from the content one would get in the U.S.

(The splash screen I get is a bug in itself - no way to close or bypass it because we're zoomed in, it sticks outside the screen and doesn't allow scrolling..)
Flags: needinfo?(hsteen)
Hallvord, yes the splash screen on the flame is what I get too, in the step A.2 on comment #15, except that for me on the device it is resize to the viewport. No issue there apart being small to read, but I can zoom in. It's the step A.4 which gives reduce screen.
Testing from the US, I don't see this problem. Karl does see something similar on his phone (gets a mobile site, but it sort of shrinks after loading) but in his opinion it's more likely to be a bug in the browser than a site/tech evang bug.
closing this because I don't see any tech evangelism issues here. Maybe Karl wants to follow up the weird zoom-out effect he saw..?
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
blocking-b2g: backlog → ---
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.