[Vertical Homescreen] Icon still appears in smart collections icon after app is deleted

RESOLVED DUPLICATE of bug 1033487

Status

Firefox OS
Gaia::Everything.me
P1
normal
RESOLVED DUPLICATE of bug 1033487
4 years ago
4 years ago

People

(Reporter: amylee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-VH-bug-bash][systemsfe])

(Reporter)

Description

4 years ago
Steps to reproduce:

1. Add an app to one of the smart collections (I added it to games collection).
2. Delete the app from homescreen. The Smart collection icon on homescreen still shows the icon of the app after it was deleted.
Nominating as the Smart Collection icon is not refreshed even after entering it.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
We need a little bit more information before making a blocking call here.

1. Does the app disappear from the collection as well when you try to open the collection?
2. Does the issue fix itself post a phone restart?
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking?]
Keywords: qawanted
(Reporter)

Comment 3

4 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> We need a little bit more information before making a blocking call here.
> 
> 1. Does the app disappear from the collection as well when you try to open
> the collection?
> 2. Does the issue fix itself post a phone restart?

1. The app disappears from the smart collection as well but the icon that is in the smart collections icon doesn't go away. 

2. When I restart the phone, the icon is still still in the smart collections icon.
It sounds like we are not making the proper icon refresh calls on app install/uninstall, so we are left with the stale smart collections icon.

Updated

4 years ago
Keywords: qawanted
This implies the collection icon is wrong on the homescreen post deletion. UX - Is this a blocker from your perspective?
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 6

4 years ago
I have experienced this a lot while using my device and find it confusing and frustrating, but I'm not sure I'd hold the release on it. Flagging Peter for his thoughts.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pdolanjski)

Updated

4 years ago
Blocks: 1017954
No longer blocks: 1015336
blocking-b2g: 2.0? → ---
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking-]
Patryk, what are your thoughts here?  This could be confusing, but I suspect most people won't pay too much attention to the little icons within the Collections icon.
Flags: needinfo?(pdolanjski) → needinfo?(padamczyk)
I can't seem to replicate this. Works for me on yesterday's master.
+ Installed an app from marketplace (cut the rope)
+ Made a new collection called "games"
+ The collection embedded the cut the rope icon into the homescreen icon
+ I deleted cut the rope and the collection homescreen icon updated accordingly
Flags: needinfo?(padamczyk)

Comment 9

4 years ago
see https://bugzilla.mozilla.org/show_bug.cgi?id=1033487#c20 for more details
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1033487
No longer blocks: 1017954
You need to log in before you can comment on or make changes to this bug.