[Flatfish][Homescreen] Can't exit first-run experience

VERIFIED FIXED

Status

Firefox OS
Gaia::First Time Experience
P1
blocker
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: rillian, Assigned: chens)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Flatfish][TCP])

Attachments

(2 attachments)

I flashed a build of today's master branch. At the end of the first run experience, I get to the screen which instructs me to swipe up to enter the homescreen. When I do so there is no effect.

The page scrolls, including the new recede effect, but nothing happens when I swipe with one or two fingers from the bottom. There's no mention of app switching in the logcat output; it's like the gesture isn't recognized.
Component: Gaia::Homescreen → Gaia::First Time Experience

Comment 1

4 years ago
The issue still reproduces in today's master build.

DUT: Flatfish
Gaia: b5b28eb0fa1f84244ee03d07ad70ec94b45721e8
Gecko:072d7e9cadbf0f8ffdbc9b150a90d176bc5d3ef7
B2G: 2.1.0.0-prerelease
firmware revision: flatfish_20140704-0036
Platform version : 33.0a1
(Reporter)

Comment 2

4 years ago
14:43 < mandeep_> don't know if this is relevant but I flashed a 2.1 build 
                  recently and had a broken homescreen also, fixed by building 
                  and flashing only gaia on top
(Reporter)

Comment 3

4 years ago
On today's v2.0 branch, I get the following in logcat when I make the swipe-up gesture with one or two fingers.

E/GeckoConsole( 1271): [JavaScript Error: "TypeError: app is null" {file: "app://system.gaiamobile.org/js/homescreen_window.js" line: 78}]

This doesn't happen with master, although the apparent behaviour is the same.

Comment 4

4 years ago
I build also a fresh build of gaia:

commit cfa144ea2400f99db77669c9954bb2cdeaac2526
(Sat Jul 5 14:06:27 2014 +0800)

I'm also not able to exit the first-run experience. any idea to kill it per adb?

i booted with logcat after flashing only gaia and the only relevant line seems to be that one:

E/GeckoConsole( 4151): Content JS ERROR at app://homescreen.gaiamobile.org/shared/js/homescreens/vertical_preferences.js:44 in init/doInit/<: Preferences store: Cannot get access to the Store

maybe its related a bit to that bug 1021327 because flatfish had a problem with the default vertical homescreen?
Duplicate of this bug: 1033957
Whiteboard: [TCP] → [Flatfish][TCP]

Comment 6

4 years ago
Setting severity as "blocker" as the OS is unusable with this bug.

The last viable build from the vendor without this bug is almost 3 weeks old and it has a serious issue (bug 1028374 ).

Who do we need to flag down or how can we get this bug fixed?
Severity: normal → blocker
Priority: -- → P1
(Assignee)

Comment 7

4 years ago
For developers, we can use |NOFTU=1 DEVICE_DEBUG=1 GAIA_DEVICE_TYPE=tablet make reset-gaia|
to prevent getting stuck in FTU app.

And I found something strange in home_gesture.js: https://github.com/mozilla-b2g/gaia/blob/e0dac9efaf4c1b0d1ea0f8d02cf1e935ff21ecee/apps/system/js/home_gesture.js#L105 

homeBar's visible state was not changed, and this might be the root cause for not able to 
swipe back to homescreen.
Maybe Iean has some insight and maybe knows when a fix is going to be available?
Flags: needinfo?(iean.lin)

Comment 9

4 years ago
We didn't look into this issue. We thought this was related to Gaia. Please advise. Thanks.

Comment 10

4 years ago
Sorry, typo. Gaia or Gecko.
(Assignee)

Comment 11

4 years ago
Created attachment 8457784 [details] [review]
Pull request

When user turns on tablet for the first time, FTU launcher will startup and tries to unlock the lockscreen, but home gesture still receives lockscreen-appopened event and hides home panel. This patch will check if FTU is running and then decide to hide home panel or not.
Assignee: nobody → shchen
Attachment #8457784 - Flags: review?(etienne)
Flags: needinfo?(iean.lin)
Comment on attachment 8457784 [details] [review]
Pull request

Thanks!
Attachment #8457784 - Flags: review?(etienne) → review+
(Assignee)

Comment 13

4 years ago
Created attachment 8457906 [details] [review]
Pull request - 2

Found home gesture should listen to |lockscreen-appclose| instead, this patch enables us to have home gesture without changes existing code logic.
Attachment #8457906 - Flags: review?(etienne)
Comment on attachment 8457906 [details] [review]
Pull request - 2

r=me with the home_gesture_test.js updated
Attachment #8457906 - Flags: review?(etienne) → review+
(Assignee)

Comment 15

4 years ago
Merged to master
https://github.com/mozilla-b2g/gaia/commit/1c9eb3d16167c2e5a9f7789eb46ee17830e6054e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Keywords: verifyme
I can confirm the issue is resolved with a build gaia from today's master.
Status: RESOLVED → VERIFIED
Per Comment 16 ,clear "verifyme".
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.