new correlations busts middleware.ini overrides

RESOLVED FIXED in 93

Status

RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: rhelmer, Assigned: rhelmer)

Tracking

unspecified

Details

(Whiteboard: [config change])

(Assignee)

Description

4 years ago
There's an override for this in the middleware.ini - I am not sure how we can do this for the prod push other than to make the code and config change at the same time.
(Assignee)

Comment 1

4 years ago
Sending        files/stage/etc-socorro/middleware.ini
Transmitting file data .
Committed revision 89932.
Status: NEW → ASSIGNED
Summary: stage mware busted with ImportError: Unable to import socorro.external.http.correlations.Correlations → new correlations busts middleware.ini overrides
(Assignee)

Updated

4 years ago
Whiteboard: [config change]
(Assignee)

Updated

4 years ago
Target Milestone: --- → 92
(Assignee)

Comment 2

4 years ago
After discussing with Adrian, I am going to put the old code back then make the new code live by modifying config.

Theoretically we could cause this bustage to happen on jenkins if the integration test used the same middleware.ini overrides that stage/prod do, but we can't drop it in as-is because jenkins does not have a testing hbase available so crash storage would not work.
(Assignee)

Comment 3

4 years ago
So I can confirm that the config change I pushed to stage in comment 1 works:

https://crash-stats.allizom.org/report/list?product=Firefox&range_value=7&range_unit=days&date=2014-07-02&signature=js%3A%3AGetLengthProperty%28JS%3A%3AValue+const%26%2C+JS%3A%3AMutableHandle%3CJS%3A%3AValue%3E%29&version=Firefox%3A33.0a1#tab-correlations

However to make the transition smoother I have opened this PR so the old code will be in place, and the old config will still work (correlations may not actually work in the UI for the short transition period between code push and config change):

https://github.com/mozilla/socorro/pull/2163

Comment 4

4 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/c6a18c887e4162a99c1257b73e26ea2eeab7788e
bug 1033584 - add old correlations so middleware will not break before
config change

https://github.com/mozilla/socorro/commit/af4a481c58dacf0968e9dd79ea10a84f87473226
Merge pull request #2163 from rhelmer/bug1033584-put-old-correlations-code-back

bug 1033584 - add old correlations so middleware will not break before
(Assignee)

Comment 5

4 years ago
OK landed, reverted the config change to see if it works as intended:

Sending        files/stage/etc-socorro/middleware.ini
Transmitting file data .
Committed revision 89934.
(Assignee)

Comment 6

4 years ago
Alright, now that old code is there middleware starts up and works - correlations UI works ok, so re-landing.

Sending        files/stage/etc-socorro/middleware.ini
Transmitting file data .
Committed revision 89950.

Updated

4 years ago
Target Milestone: 92 → 93
(Assignee)

Comment 7

4 years ago
Reconfigured to run new correlations:

Sending        files/prod/etc-socorro/middleware.ini
Transmitting file data .
Committed revision 90229.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.