Corruption is seen on list items, on touching them.

RESOLVED DUPLICATE of bug 1022167

Status

()

Core
Graphics: Layers
--
major
RESOLVED DUPLICATE of bug 1022167
4 years ago
4 years ago

People

(Reporter: Sushil, Unassigned)

Tracking

2.0 Branch
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
On b2g v2.0 tip, on a H/W Overlay device, check this:
1. Settings --> Display --> Screen timeout.
2. In "Select" screen, touch different list items: 1 minute, 2 minutes, etc.
3. Corruption is seen on list items, when they are touched.

This issue is seen even when HWC is disabled (to force GPU Composition).
(Reporter)

Comment 1

4 years ago
The issue occurs in GPU Composition as well. By seeing the corruption, it seems the release fence of FrameBuffer layer is not being honored.

Sotaro, I guess you had fixed similar issue earlier but I don't remember Bugzilla #. Please check this issue.
Flags: needinfo?(sotaro.ikeda.g)
It is Bug 1022167. Once it is nominated to b2g-v1.4, but it was put to backlog :-(
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Sotaro Ikeda [:sotaro] from comment #2)
> It is Bug 1022167. Once it is nominated to b2g-v1.4, but it was put to
> backlog :-(

It is fixed only on master. b2g-v2.0 still has this problem.
(Reporter)

Comment 4

4 years ago
Yes, I have verified that patch in Bug 1022167 fixes the corruption. Marking this bug as DUP.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022167
You need to log in before you can comment on or make changes to this bug.