[Collections] Icons overlay "Connect to the Internet" message when browsing offline a Smart Collection

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Everything.me
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: crdlc)

Tracking

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [2.0-VH-bug-bash][systemsfe])

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8449728 [details]
Overlayed text - Screenshot

Build Information
Device: Flame
Gaia      3bfe47c58c959c42f5ffe0309b5380ea514ccd69
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f40e767ea283
BuildID   20140702000201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220


Steps to Reproduce
1. Add 12 icons to a Smart Collection
2. Disconnect the Internet Connection
3. Enter the Smart Collection

Actual Results
"Connect to the Internet to get apps for Smart_Collection_Name" is partially hidden by the last row of icons. See screenshot for details.
(Reporter)

Comment 1

4 years ago
The message seems to be hardcoded in the background image, which doesn't look clean.
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
(Reporter)

Comment 2

4 years ago
Created attachment 8449778 [details]
1.4 message - Not overlayed - Screenshot

Regression from 1.4. See this screenshot.
Not sure I'd block on something like this, but we can discuss this in triage.
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking?]
UX - Need input on whether you think this is a blocker or not.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 5

4 years ago
Well, it's a regression and, since home and lock screen have to be perfect, I think we have to block on it. Checking with Peter.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(pdolanjski)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?] → [VH-FL-blocking-][VH-FC-blocking+]
This looks very busted from a user perspective.  I agree with the blocking call.
Flags: needinfo?(pdolanjski)
(Assignee)

Comment 7

4 years ago
Created attachment 8451588 [details]
Github pull request

Basically the problem is that the <gaia-grid> element has not height because items are translated via transformations. I don't assign this bug to me because it is just an idea but it seems not to be the best approach. Maybe you have a happy idea to fix it. I didn't see another one :( Thanks
Attachment #8451588 - Flags: feedback?(ran)
Attachment #8451588 - Flags: feedback?(kgrandon)
Comment on attachment 8451588 [details]
Github pull request

I think I would be fine with this. Also left an alternative for you to consider.
Attachment #8451588 - Flags: feedback?(kgrandon) → feedback+
Assignee: nobody → crdlc
(Assignee)

Comment 9

4 years ago
Comment on attachment 8451588 [details]
Github pull request

Addressed comments Kevin
Attachment #8451588 - Flags: review?(kgrandon)
Comment on attachment 8451588 [details]
Github pull request

Seems like this is good for now. I'll go ahead and take the review for Ran as he's out for a while. We can clean this up more later if needed. Thanks!
Attachment #8451588 - Flags: review?(kgrandon)
Attachment #8451588 - Flags: review+
Attachment #8451588 - Flags: feedback?(ran)
Created attachment 8451887 [details] [review]
Github pull request

I made one small change to use the existing pixelHeight property instead of defining a new one. Thanks!
Attachment #8451588 - Attachment is obsolete: true
Attachment #8451887 - Flags: review+
Master: https://github.com/mozilla-b2g/gaia/commit/eca491bcbb640ff79a5834e989273a73da25c2b4
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

4 years ago
It is no very important but I prefer to do the changes by myself and land my patches next time
(In reply to Cristian Rodriguez (:crdlc) from comment #13)
> It is no very important but I prefer to do the changes by myself and land my
> patches next time

Sure thing, sorry about that!
v2.0: https://github.com/mozilla-b2g/gaia/commit/ac859668f40e35addcd9452ef5960d51a3215a7e
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S6 (18july)

Comment 16

4 years ago
Created attachment 8532355 [details]
verify_video.MP4

This issue has been verified successfully on Flame v2.1 & v2.0
See attachment: verify_video.MP4
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        5655269098c7e82254e56933f1af05b4abe2a2f3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/86608c9389b5
Build-ID        20141204001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141204.034958
FW-Date         Thu Dec  4 03:50:09 EST 2014
Bootloader      L1TC00011880

Flame 2.0 versions:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ff1100ba2ab8
Build-ID        20141204000228
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141204.040425
FW-Date         Thu Dec  4 04:04:36 EST 2014
Bootloader      L1TC00011880

Updated

4 years ago
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.