search keyword doesn't match in marketplace

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: atiqueahmedziad, Unassigned)

Tracking

Points:
---

Details

Attachments

(1 attachment)

Created attachment 8449988 [details]
123.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

My app name in marketplace is  "Daily Duas". So I search "duas" in the marketplace search bar so that I can find my app. (Duas is a popular keyword, so I have search with it, as people will search with this keyword)   


Actual results:

I haven't got my app in the results. Also didn't get any app related to keyword -"duas". 


Expected results:

I should have got my app list there and also all the other app with keyword - "duas" listed there.
I searched for "daily duas" and the app was first in the list.

I search for "duas" and the app was 13th in the list.

The problem with such a small search term is that first, it gets analyzed and the "s" removed to remove the plural form to help find root words. Now we only have "dua".

We also do fuzzy searching along with term searching so we search "duas" but also matches words that start with "d" and are one or two edit distance away. Since this is only a 4 letter search query pretty much anything starting with "d" and is 4 letters long is going to match with this fuzzy query included. I believe this is why "Dots and Boxes" shows up, and all the apps by the "Double Duck" publisher.

I'm not sure what other "duas" apps we may have but I didn't see any scrolling through the other 92 apps returned.

I believe the search is working as expected but I'll leave open if anyone else wants to chime in on how we may possibly tweak our searching algorithm.
We think this works as intended. Re-open with rationale if you think otherwise. Thanks for the bug report though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.