Closed Bug 1033998 Opened 6 years ago Closed 6 years ago

Reduce log spam from camera code on KK

Categories

(Core Graveyard :: Widget: Gonk, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
mozilla33
blocking-b2g -
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed
firefox33 --- fixed
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: mwu, Assigned: mwu)

References

Details

Attachments

(1 file)

This patch switches to standard android logging macros and makes sure logging is disabled by default. Logging can be reenabled by setting LOG_NDEBUG in the directory.
Attachment #8450098 - Flags: review?(sotaro.ikeda.g)
Comment on attachment 8450098 [details] [diff] [review]
Reduce camera log spam on KK

Review of attachment 8450098 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thansk!
Attachment #8450098 - Flags: review?(sotaro.ikeda.g) → review+
https://hg.mozilla.org/mozilla-central/rev/24ebcda3b781
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Duplicate of this bug: 1035292
Can we make sure to land this on 2.0 as well
blocking-b2g: --- → 2.0?
(In reply to bhargavg1 from comment #5)
> Can we make sure to land this on 2.0 as well

We can get this uplifted via approval in 2.0, no reason to block here. Blocking flag is used for release blocking issues typically
blocking-b2g: 2.0? → -
:mwu, can you seek aurora approval here ?
Flags: needinfo?(mwu)
Comment on attachment 8450098 [details] [diff] [review]
Reduce camera log spam on KK

Approval Request Comment
[Feature/regressing bug #]: Bug 959505 (Camera support on gonk-kk)
[User impact if declined]: Logging on gonk-kk is unusable with the camera on.
[Describe test coverage new/current, TBPL]:
[Risks and why]: Minimal - logging only change.
[String/UUID change made/needed]: None
Attachment #8450098 - Flags: approval-mozilla-aurora?
Flags: needinfo?(mwu)
Comment on attachment 8450098 [details] [diff] [review]
Reduce camera log spam on KK

Aurora+
Attachment #8450098 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.